Spam not to Junk

Discussion in 'Installation/Configuration' started by Steffan, Nov 8, 2017.

  1. Steffan

    Steffan Member

    Hello,

    i have read a lot of old posts abouth this but cant find my answer.
    Running latest ispconfig
    Centos 7
    In mysql move spam to junk is Y
    but when i look at the maillog:
    Nov 8 15:35:46 mail01 amavis[11902]: (11902-01) Passed SPAMMY {RelayedTaggedInbound}, [104.149.186.66]:35179 [104.149.186.66] <[email protected]>

    And in the mailDir:
    new/1510151746.M745156P11988.mail01,S=11024,W=11123
    X-Spam-Flag: YES
    X-Spam-Score: 6.81
    X-Spam-Level: ******

    But the email is in Maildir/new And not in Maildir/.Junk
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    A spam filter must be selected for the domain or mailbox. If a filter is defined for the domain and the mailbox, the settings from the mailbox are in place. If only the domain has a filter, it’s also used for the mailbox. In short: Mailbox overwrites domain – this is the only way, to define individual policies for each mailbox. If you use an alias, the policy for the domain applies.
     
  3. Steffan

    Steffan Member

    i dont understand i think.
    There is a spamfilter
    as you can see the email is marked as spam.
    Do i have to change something in the mailpolicys settings?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The mail is moved by the LDA to the junk folder. Do you use courier or dovect imap? When you are using dovecot, then check the .sieve file if it contains the rule to move the mail to junk. If you use courier, then this rule is in the mailfilter file of the mailbox.
     
  5. Steffan

    Steffan Member

    In ispconfig > server settings
    POP3/IMAP Daemon: Doveot
    Mailfilter Syntax : Sieve

    if i go to
    /var/vmail/domain/mailbox
    i see:
    drwx------ 4 vmail vmail 4.0K Nov 9 12:33 .
    drwxrwx--- 8 vmail vmail 4.0K Apr 4 2017 ..
    -rw------- 1 vmail vmail 52 Nov 9 12:33 .quotausage
    lrwxrwxrwx 1 vmail vmail 21 Apr 4 2017 .sieve -> sieve/ispconfig.sieve
    -rw------- 1 vmail vmail 7.9K Oct 2 19:12 .sieve.log
    -rw------- 1 vmail vmail 11K Oct 2 17:44 .sieve.log.0
    -rw-r--r-- 1 vmail vmail 185 Apr 6 2017 .sieve.svbin
    drwx------ 9 vmail vmail 4.0K Nov 9 13:14 Maildir
    drwx------ 2 vmail vmail 4.0K Apr 4 2017 sieve

    pico sieve/ispconfig.sieve

    require ["fileinto", "regex", "date", "relational", "vacation"];


    keep;

    hmmm.
    If i look at antother domain i see the extra:
    # Move spam to spam folder
    if header :contains "X-Spam-Flag" "YES" {
    fileinto "Junk";
    # Stop here so that we do not reply on spams
    stop;
    }

    Will resync help to fix this?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Aresync might not work here, pleasetry to disable the 'move to kunk' checkbox, save, enable it again, save. Then wait a minute (or until the red indicator in the upper menu is gone) and then check if this setting has been added into the sieve file.
     
  7. Steffan

    Steffan Member

    yes that works was hopening for a global update.
    thanxs for the help
     

Share This Page