Spam Kill Level don't work

Discussion in 'General' started by Hbod, Dec 12, 2016.

  1. Hbod

    Hbod New Member

    Hi,
    I think there is an issue with the current setup.
    I've set up my filter (based on "trigger happy") with

    Level 1: 1
    Level 2: 3
    Kill Level: 4
    I've toggled "move spam to junk" active.

    The kill level just won't work. Also checked the amavisd config-file, it is set to DISCARD, not BOUNCE or something similar.

    X-Virus-Scanned: Debian amavisd-new at xx
    X-Spam-Flag: YES
    X-Spam-Score: 8.008
    X-Spam-Level: ********
    X-Spam-Status: Yes, score=8.008 tagged_above=1 required=4.5

    Something like this, which is cleary Score 8 inside the headers, still get moved into the junk folder. I have the feeling, it prob. depens on that active toggled checkbox? I would like to kill everything thats up 4, which this config cleary points out. Killing above level x.

    How can I achieve this, or even, who will fix this in ISPConfig?
    Version 3.1.1
     
    Last edited: Dec 12, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    As you can clearly see from the header, the policy where you set the kill level is not the policy that is used for this incoming email (required=4.5 vs. taglevel2 = 3). So there is no problem with the kill level, the problem is that a different spamfilter policy is used. Ensure that you have set this policy in the email mailbox AND the domain. If you set it just in the mailbox and the incoming mail is received troh an alias, then the domain setting will get applied for the alias (or a specific policy defined in spamfilter > user domain) and not the one of the mailbox as the to address is no direct match for the mailbox address.
     
    Hbod likes this.
  3. Hbod

    Hbod New Member

    True, Till, it was an alias. It's very confusing. Actually I thought the mail should be re-scanned to fit the requirements set for the target, not the alias domain. I will change that for now!

    Thank you for clarifying.
     

Share This Page