Spam & ISPConfig 3.

Discussion in 'Installation/Configuration' started by itsnedkeren, May 7, 2009.

  1. itsnedkeren

    itsnedkeren New Member

    Hi all.

    First off thanks for a great product!

    I'm having problems figuring out how to setup the spam function in ISPconfig3.

    Info:
    Spamfilter is set to "Normal" for all users
    I have not configured any black/white-list
    Spam subject used -> XJS*C4JDBQADN1.NSBN3*2IDNEN*GTUBE-STANDARD-ANTI-UBE-TEST-EMAIL*C.34X

    Please see attached screenshot!

    Question 1: Mails that are for sure spam like a spam test(see above), gets thru the system, BUT they get marked as "SPAM!!!" in the subject. Why are they not bounced, removed, deleted OR moved to the email address I specified in the "Quarantine" tab under "Forward spam to email"???


    Question 2: What are reasonable setting for the spam function??


    Thanks in advance for any replies.

    Best regards
    Jimmy
     

    Attached Files:

    Last edited: May 7, 2009
  2. itsnedkeren

    itsnedkeren New Member

    Anyone able to assist?
     
  3. sighkick

    sighkick New Member

    I feel your pain...

    I am waiting patiently for a How To manual for ISPConfig 3 since the one produced for ISPConfig 2 is completely different.

    Appreciate it must be a mammoth task, but sure many would benefit from such a document.
     
  4. till

    till Super Moderator

    If you want to get more information about the spamfilter settings, take a look at the amavisd-new configuration. ispconfig uses a default mysql setup as described in the amavisd-new manuals.
     
  5. itsnedkeren

    itsnedkeren New Member

    Thanks for all your replies, but even with the Amavisd-new documentation I am not able to filter ANY spam from my mails :(

    I can see the spamfilter has some kind of effect as my subjects gets tagget with "***SPAM***", but selecting a kill level of 10 should get rid of a lot of spam, but even so I'm still getting many spam mails.

    I've tried to look at mysql and it seems that ISPConfig's connection is working fine as it modifies the entries, but as I said, nothing happens mail wise!

    Please someone assist me with this.

    Thanks in advance.
    Jimmy
     
  6. Ovidiu

    Ovidiu Active Member

    well, take a look at the headers of the SPAM mails getting through. what SPAM score do they have? is it above the kill level? if not, that is why they don't get killed.
     
  7. itsnedkeren

    itsnedkeren New Member

    I think I have solved the problem.

    For some reason, ISPconfig defaults to letting spam pass through.

    In the file: /etc/amavis/conf.d/50-user find the following:

    Code:
    $final_virus_destiny = D_BOUNCE;
    $final_spam_destiny = D_PASS;
    $final_banned_destiny = D_BOUNCE;
    $final_bad_header_destiny = D_PASS;

    Change

    Code:
    $final_spam_destiny = D_PASS;
    To

    Code:
    $final_spam_destiny = D_DISCARD;
    Finally issue a restart command for amavis:
    Code:
    #/etc/init.d/amavis restart
    This solved my problem, and from what I see, the values I enter in the ISPconfig config, now works and are being applied as they should. Can anyone confirm this?
     
  8. Ovidiu

    Ovidiu Active Member

    confirmed :)
     
  9. Ovidiu

    Ovidiu Active Member

  10. 3cwired_com

    3cwired_com New Member

    I will test this out and hopefully this helps. besides setting the kill level how does one tighten up on what gets killed and not killed, as I was not able to effectively kill anything, while checking the spam headers, i was still getting mail with the required kill level of 6.9. which is quite high for my likings. Please let me know how to change the kill level where it reflects in my mail headers. thanks.
     
  11. till

    till Super Moderator

    Just do exactly what is osted above to set the final spam destiny to discard. The kill level itself can be set for every spamfilter policy individually in ispconfig. Just click on the policy, enter the value that you like and click on save.
     
  12. 3cwired_com

    3cwired_com New Member

    Ok, I was actually doing that, and the changes would stay there on the screen, but wouldn't reflect in the mail headers. there was more than enough time for it to reflect maybe 1 day or 2.

    now that i started playing with it by adding more spam filter users it now starts to show in the headers.


    this problem was also happening in my ftp-users, where it was not reflecting the changes, but for some reason out of nowhere the changes that i started setting are now reflecting in the system operation.

    Just wanted to update.
     
  13. AnilKumar

    AnilKumar New Member

    Hi friends ,

    I am using the plesk vps server,
    When i used to sending the mails from the php SMTP code,
    then that mail send to spam folder,

    This is happen to when i am usied to send the mail to yahoo mail id.

    How to solve this issue.

    please help me.

    Anil Kumar

    http://anil2u.wordpress.com
     
  14. falko

    falko Super Moderator

    @AnilKumar: Please open a new thread.
     

Share This Page