spam filtering issue

Discussion in 'Installation/Configuration' started by kiddiak, Nov 16, 2011.

  1. kiddiak

    kiddiak New Member

    [solved] spam filtering issue

    Hi,

    I have a mail server, mail-01.domain.tld and mail-02.domain.tld as backup. Everything was working fine but now I think spam is getting through for all mailboxes and this is what I think went wrong:

    1. mail-01 is setup in a multi server environment
    2. mail domains and mailboxes are created
    3. mail-02 is setup as mail-01's mirror
    4. after step 3 I see that all domains and mailboxes in Spamfilter -> User/Domain do not have a server assigned to it. The only ones that have mail-01 as server are new domains and mailboxes I create after I setup mail-02. When I edit a domain or mailbox wich does not have a server the master server is selected ( probably because it's the first one ) and if I try to select mail-01 as server and save it gives me "ERROR The Server can not be changed."

    So.. would the only solution be to remove all mailboxes and domains and setup new ones? and is this a known issue? or.. do you know if this should have any impact on spam filtering, I'm getting spam to my mailbox and a clients mailbox, the same trash in both offering viagra and what not,both mailboxes are fairly new and should not get any spam :]

    ispconfig 3.0.4 ( I admit that I've never looked into "Spamfilter -> User/Domain" so this could have changed when I upgraded from 3.0.3 to 3.0.4 )
    ubuntu 10.04
    header in email contains "X-Virus-Scanned: Debian amavisd-new at mail.domain.tld" even if it does not have a server assigned but I don't see anything about spam

    Thanks in advance,
    Kiddi.
     
    Last edited: Nov 16, 2011
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig update does not change existing records in the database, it updates only the database scheme. The server select field was there in all ispconfig 3 versions. So if the records do not have a server assigned, then it was not assigned before the 3.0.4 update.

    No, try this instead: Go to the mailbox settings, set spamfilter to no, click save, edit mailbox settings again and set spamfilter to yes and save. Then check if the record in Spamfilter User/Domain is correct now.
     
    Last edited: Nov 16, 2011
  3. kiddiak

    kiddiak New Member

    solved

    yub I think this solved my issue, header for new mail has changed from

    X-Virus-Scanned: Debian amavisd-new at mail.domain.tld

    to...

    X-Virus-Scanned: Debian amavisd-new at mail.domain.tld
    Authentication-Results: mail-01.domain.tld (amavisd-new); dkim=pass
    [email protected]

    so I guess spamfiltering is working now, thanks! :]
     
  4. kiddiak

    kiddiak New Member

    another possible explanation for this is maybe if the /var/vmail folder stores info about the spam user and server ID wich has changed from like 11 to begin with and is now ..19 I think. I've had to completely reinstall the mail server several times, most often due to folder/file permission issues leading to no mail recieving and so on..
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The infor is stored only in the ispconfig DB. But in the /var/vmail folder are the filter recipes stored, so if you e.g. had the "move junk to folder" option activated and deleted the contents of /var/vmail, this filter recipe will get removed and spam will be in the inbox gain.

    If you have any file permission issues in that folder, just run:

    chown -R vmail:vmail /var/vmail

    to fix that.
     
  6. kiddiak

    kiddiak New Member

    well this was a headache when no mail was arriving, and "chown -R vmail:vmail /var/vmail" did not seem to change ownership of the hidden file /var/vmail/.mailfilter for some reason wich was leading to no mail arriving. Another case I had to chmod 755 /var/run/courier/authdaemon ( if I remember correctly), don't know why but that was cousing sendmail to spit out errors and mail ended up in the file /var/mail/vmail, or not at all
     

Share This Page