Spam Assassin problem during sa-update

Discussion in 'Installation/Configuration' started by Been Told, Feb 24, 2010.

  1. Been Told

    Been Told Member

    My Spam Assassin was throwing false errors because of the date bug described here:
    http://www.faqforge.com/linux/how-to-fix-the-spamassassin-bug-with-the-fh_date_past_20xx-rule/

    So I ran "/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update" as described in the tutorial. But that gave me this output:
    Any ideas anyone? The server is running on Debian Lenny, ISPConfig 2.

    Also, sometimes when I write to someone and they reply to me, there's a "-->" just before my e-mail. This also happens when I send e-mail to myself. So it must be something on my server.
     
    Last edited: Feb 24, 2010
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you try this?
    Code:
    aptitude install liblwpx-paranoidagent-perl
     
  3. Been Told

    Been Told Member

    Looks like that did it! :) I ran the sa-update line again and now it finished without errors. Danke Falko :)
     
  4. Mikymike

    Mikymike New Member

    I've done a brand new install of ISPConfig 2.2.36 after following completly the perfect setup for my debian 5 lenny distro and had the same problem.

    Code:
    aptitude install liblwpx-paranoidagent-perl
    or
    Code:
    apt-get install liblwpx-paranoidagent-perl
    Should be missing or in the installation script or in the perfect setup

    Then I've done:
    Code:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
    After doing those commands my spamassassin is filtering now correctly.

    Thank you for everything and for your very good work on ISPConfig

    Michael
     
    Last edited: Jun 9, 2010

Share This Page