Spam and virus quarantine email forwards not working

Discussion in 'Installation/Configuration' started by primal23, Sep 3, 2009.

  1. primal23

    primal23 New Member

    Here is the message from mail.warn
    Sep 3 14:09:17 server1 postfix/smtpd[23819]: warning: Illegal address syntax from server1.motionauto.com[127.0.0.1] in MAIL command: postmaster@server1.motionauto.com
    Sep 3 14:09:17 server1 amavis[21933]: (21933-01) (!)SEND via SMTP: postmaster@server1.motionauto.com -> ,ENVID=AM..20090903T210917Z@server1.motionauto.com 501 5.1.7 Failed, id=21933-01, from MTA([127.0.0.1]:10025): 501 5.1.7 Bad sender address syntax
    Sep 3 14:09:17 server1 amavis[21933]: (21933-01) (!)FAILED to notify admin: 501 5.1.7 Failed, id=21933-01, from MTA([127.0.0.1]:10025): 501 5.1.7 Bad sender address syntax

    I have bypass header check set to yes, and bad header lover to yes. Was wondering what I could possibly be doing wrong? :(

    Thanks :)

    Edited to say I can send it successfully to a file, but would like to have it as email to review in case of accidental filtering. Thanks again
     
    Last edited: Sep 4, 2009
  2. primal23

    primal23 New Member

    Bump

    Any help/ideas would be appreciated :)
     
  3. falko

    falko Super Moderator

    I have no idea what's wrong... :(
     
  4. primal23

    primal23 New Member

    Thank you for trying though, I do appreciate it!
     
  5. nouvtech

    nouvtech New Member

    Hello,

    I'm trying a solution I've found in Internet.

    You should specify a new variable in an amavis conf file (e.g. /etc/amavis/conf.d/50-user).

    Code:
    $mailfrom_notify_admin = 'webmaster@my_server.net';
    I'll tell you here as soon as possible if it works.
     
  6. primal23

    primal23 New Member

    Well I got the emails working, now I have a problem with Clamav, it says it cannot run it permission denied. Always something. I appreciate the help, and if anyone has ideas about the Clamav it would also be appreciated. :)
     
  7. falko

    falko Super Moderator

    What's the exact error message?
     
  8. primal23

    primal23 New Member

    I actually got it solved, didnt have clamav in the amavis group under /etc/group. Not getting an error message, but I am not 100% confident that it is scanning. :eek:
     
  9. primal23

    primal23 New Member

    Well I didnt get it solved after all, here is the error message in my mail.log and mail.err

    amavis[8120]: (08120-01) (!!)run_av (ClamAV-clamd) FAILED - unexpected , output="/var/lib/amavis/tmp/amavis-20090910T105535-08120/parts: lstat() failed: Permission denied. ERROR\n"
    Sep 10 10:55:36 server1 amavis[8120]: (08120-01) (!!)ClamAV-clamd av-scanner FAILED: CODE(0xa677448) unexpected , output="/var/lib/amavis/tmp/amavis-20090910T105535-08120/parts: lstat() failed: Permission denied. ERROR\n" at (eval 98) line 543.
    Sep 10 10:55:36 server1 amavis[8120]: (08120-01) (!!)WARN: all primary virus scanners failed, considering backups
     
  10. nouvtech

    nouvtech New Member

    Spam and virus quarantine email forwards working !

    It works !! (after have restarted amavis, clamav and spamassassin)
     
    Last edited: Sep 11, 2009
  11. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /var/lib/amavis/
    ?
     
  12. primal23

    primal23 New Member

    Ok here is that output:

    total 24
    drwxr-xr-x 6 amavis amavis 4096 2009-09-11 08:15 .
    drwxr-xr-x 72 root root 4096 2009-09-10 12:11 ..
    srwxr-x--- 1 amavis amavis 0 2009-09-11 08:15 amavisd.sock
    drwxr-xr-x 2 amavis amavis 4096 2009-09-11 08:15 db
    drwx------ 2 amavis amavis 4096 2009-09-11 08:20 .spamassassin
    drwxr-xr-x 4 amavis amavis 4096 2009-09-10 15:25 tmp
    drwxr-xr-x 64 amavis amavis 4096 2009-09-10 15:25 virusmails
     
  13. falko

    falko Super Moderator

    Looks ok to me, but you can try this:
    Code:
    chmod 777 /var/lib/amavis/tmp
     

Share This Page