Sometimes FTP connection problems (proftpd)

Discussion in 'Installation/Configuration' started by JohnSmith, May 10, 2006.

  1. JohnSmith

    JohnSmith New Member

    Maybe I'm wrong here but on another system without ISPConfig the problem does not occour...

    I use ISPConfig on an Debian Sarge 3.1 System with proftpd.
    unregulary I get "can't connect" statements while I try to connect via FTP. If I retry it'll work (mostly)

    IdentLookups in the <Global> Section is turned "off" but this does not help.
    Anyone with an idea?
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you try both active and passive mode in your FTP client?
  3. JohnSmith

    JohnSmith New Member

    Sorry, I've forgotten to describe that I#ve already have tested that.
    Neither active still passive mode does bring any improvement.
  4. falko

    falko Super Moderator ISPConfig Developer

    When you restart Proftpd, do you see errors? Do you use a firewall? If so, what happens when you turn it off?
  5. JohnSmith

    JohnSmith New Member

    Restart without any error and no Firewall is used.
    The main problem is, that the connection problems are not regulary or under special conditions. e.g. I use an PHP Script wich connect by the PHP FTP Class. From about 100 connects with this script about 8 - 16 times the connection does only work at a second or third try. Thats to much to just ignore it...
    There is not much load on that machine, so the environment can not be the reason. The max. concurrent connection is 600 but that does not matter because a max of about 150 connection is the absolute max I've ever noticed.
  6. MathieuMa

    MathieuMa New Member

    I remember seeing a similar issue being discussed about on the forum, for servers under Debian.

    NB : Got the same issue as well, sometime first connexion is not OK and I have to reconnect
  7. falko

    falko Super Moderator ISPConfig Developer

    Does it happen only with your PHP script, or also with a regular FTP client like SmartFTP?
  8. Neocoolrox

    Neocoolrox New Member

    I,m with the same problem in a Debian Box, I can connect sometimes and sometimes not. I have tried pretty much everything, firewall, quotas, passive mode. If anyone have any update on the subject. Thanks in advance.

    Editing - In my case it happens both with scripts or with ftp clients or browsers.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in your syslog or xferlog?

Share This Page