something wrong with mail & hostname

Discussion in 'Installation/Configuration' started by mantasman, Jan 12, 2006.

  1. mantasman

    mantasman New Member

    if i send message myself, i see such error in /var/log/maillog:
    Code:
    B7A094F2043F: to=<web11_me@localhost.localhost>, orig_to=<postmaster@thehostman.net>, relay=none, delay=1, status=bounced (Host or domain name not found. Name service error for name=localhost.localhost type=A: Host not found)
    
    i'm 100% sure, email exists. and web11_me exists too. and if ping localhost.localhost, 127.0.0.1 (so my server) replies.
    ftp, www, sending emails work. the only one which doesnt is receiving emails :/
    i'm under fedora core 4, setuped by "the perfect setup"
     
  2. falko

    falko Super Moderator

    What's in /etc/resolv.conf and /etc/hosts?
     
  3. mantasman

    mantasman New Member

    Code:
    cat /etc/resolv.conf
    nameserver 127.0.0.1
    nameserver 203.141.128.34
    nameserver 203.141.128.33
    
    and
    Code:
    cat /etc/hosts
    
    # 'hosts' file configuration.
    
    127.0.0.1       indre.local     localhost
    219.117.228.243 indre   indre
    
     
  4. till

    till Super Moderator

    Try to change your /etc/hosts file to this:

    Code:
    # 'hosts' file configuration.
    
    127.0.0.1       indre.local     localhost     localhost.localhost
    219.117.228.243 indre   indre
    
     
  5. mantasman

    mantasman New Member

    tried. didnt helped.

    and i tried to set mydomain/hostname to my real domain.tld. this gets me "looppbacking to myself" error.

    a part of a log:
    Code:
    Jan 13 01:18:39 spider-webhosting postfix/smtp[20921]: 7CEA54F20427: to=<web11_me@mail.thehostman.net>, orig_to=<postmaster@thehostman.net>, relay=none, delay=1, status=bounced (mail for mail.thehostman.net loops back to myself)
    
    as i see from logs, it's received to postmaster@thehostman.net succesfully. but it fails to forward it to local mailbox. which seems to be working too :)

    what should i enter into mydomain and myhostname in /etc/psotfix/main.cf ?

    so, summary:
    if myhostname and/or mydomain set to any local name - fail with "cant find A entry" error

    if these two set to my domain - fail with "loops back to myself"
     
  6. falko

    falko Super Moderator

    This is easy to solve: put mail.thehostman.net at the bottom of /etc/postfix/local-host-names (where it says that you're allowed to make manual entries) and restart Postfix:
    Code:
    /etc/init.d/postfix restart
     
  7. mantasman

    mantasman New Member

    argh, i just removed ispconfig as i was sooooooooo angry :/

    anyway, thanks for suggestion.
    i will try this tomorrow.

    or, and one more question... how can end-user create subdomain?

    and can end-client login into ftp with it's main password from ISPconfig?
     
  8. falko

    falko Super Moderator

    So close to the solution... :(

    Under Co-Domains. However, the subdomain must be set up in DNS first.
    No, clients can login only to ISPConfig. Client are ISPConfig users, but not system users.
    The users you create under "User & Email" can use FTP.
     
  9. mantasman

    mantasman New Member

    i installed all the stuff again but i'm getting stupud cant login error, because authdaemond error because it tries to lookup something in postgreSQL

    i dont want to run all the setup again :/
    which step did i miss?
     
  10. falko

    falko Super Moderator

    Did you follow the Fedora 4 "Perfect Setup"? I don't mention PostgreSQL there so I guess you did something wrong (maybe a typo...). You should try to use PuTTY on your Windows machine and simply copy and paste the commands from the tutorial to the shell to avoid typos.
     
  11. mantasman

    mantasman New Member

    yes, i followed.
    and i'm unable to use PuTTY as i'm under Gentoo ;)
    will try today again.
     
  12. till

    till Super Moderator

    OK, a kde or gnome shell console and the ssh command will be fine too ;)
     
  13. mantasman

    mantasman New Member

    i know this very well ;)

    i'm not new to linux. but i'm total newbie in web servers managing (at the moment, setuping only :) )

    finally emails are working. but only partiately.

    i cant login to email and ftp (proftpd) both. as i see from logs, there's something wrong with authd. and i still finished near-complete perfect setuping :/

    i see this error in mail logs:
    Code:
    authdaemond: Connection to server 'pgsql.example.com' userid 'admin' database 'template1' failed.
    
    i think i cant login into ftp because of the same reason.
    how can i fix that? please dont sugggest to reinstall everything again..... :'(
     
  14. falko

    falko Super Moderator

    Have you tried to set up virtual hosting with Postfix on top of the Fedora Core 4 tutorial? This doesn't work with ISPConfig! You have to follow only the "Perfect Setup" for FC4 ( http://www.howtoforge.com/perfect_setup_fedora_core_4 ), and at the end it should work. Don't try to configure Postfix and Proftpd to use MySQL databases.
     
  15. mantasman

    mantasman New Member

    no, no.
    after i uninstalled ISPconfig (which was working near perfectly at that moment) i tried to reconfigure everything by "install VHCS2 on fedora core" howto, founded on vhcs.net.
    after that, i removed all the packages, list in "Perfect Setup" (except courier-sasl & courier-sasl-devel) and runned trough the whole howto once more.

    i disabled postgreSQL and MySQL modules of authdaemond and now i get just "LOGIN FAILED" error in /var/log/maillog
     
  16. falko

    falko Super Moderator

    Maybe you should consider a clean re-install?
     
  17. mantasman

    mantasman New Member

    apt-get threatens to remove gnome and many system-config-* applications if i remove cyrus-sasl :/

    anyway, why do i need X11 if server is thousands miles away from me :)

    if this 'd fail, is there any ways to restore fedora core 4 to it's original state without inserting cds etc?
     
  18. mantasman

    mantasman New Member

    spent the whole night for removing packages and reinstalling them......
    and nothing!!!!!!!!!

    i still get same authdaemond error that it tries to connect to pgsql.example.com

    and i cant connect to ftp too :'(

    i even removed all the config directories related to postfix and reinstalled em but nothing :/
     
  19. mantasman

    mantasman New Member

    i found that sasl seems to be not working. for example:
    with saslpasswd i add username "me" and password "me". then write saslauthd1-checkpass -u me -p me and it gives me such error:
    Code:
    NO: -13 (authentication failure)
    sasldblistusers says:
    Code:
    user: me realm: thehostman.net mech: DIGEST-MD5
    user: me realm: thehostman.net mech: CRAM-MD5
    user: me realm: thehostman.net mech: PLAIN
    wtf is here?
     
  20. till

    till Super Moderator

    ISPConfig does not use the saslpasswd mechanism at all. ISPConfig uses system users and /etc/passwd and /etc/shadow as source for sasl authentication.
     

Share This Page