Some strange problems with fresh installation, I can't solve without assistance.

Discussion in 'Installation/Configuration' started by koffu, Feb 8, 2009.

  1. koffu

    koffu New Member

    Hi!

    I have setup my own web server on Debian etch with ISPconfig manager. Install was finished by error:
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!ISPConfig system is now up and running!

    I checked hostname with:
    hostname
    hostname -f

    all was correctly, root password was correctly too. I extract installer again and do:
    mysql> create database ispconfig_db;
    $mysql -u root -p ispconfig_db < ./install_ispconfig/db_ispconfig.sql

    all start work, but I get some errors:

    • field IP address in ISP site page is empty, the same problem in DNS-manager.
    • apache will redirect all queries to external ip to "It works!" page. This error I solve replacing "RedirectMatch ^/$ /sharedip/" directive in /etc/apache2/sites-available/default.
    • and when I create domains add appropriate DNS records to they, BIND don't see any of them. I run named in chroot and I don't see any changes in configs after adding domain via ISPconfig. Maybe file permissions problem? All files have 755 mode and bind:bind owner and group.


    I have setup some servers with ISPconfig ago on Ubuntu and Debian, but I hav'nt any problems. I really confused:confused:.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not install the mysql dump manually. Please uninstall ISPConfig by running:

    /root/ispconfig/uninstall

    and then reinstall it again and make sure that you use the mysql root user for ispconfig and that no mysql database exists with the name that you want to use for your ispconfig database.
     
  3. koffu

    koffu New Member

    I tried reinstall on those server, but ISPconfig says at the end of install, while creating mysql database, access denied for user 'root'@'localhost'. Before this I setup password as for 'root', as for 'root'@'localhost' and 'root'@'myhostname' and destroyed all databases, belong to ISPconfig. Maybe I do something wrong, while configure mysql? I not sure, because I do step-by-step [URL="http://howtoforge.com/perfect_setup_debian_etch]by this topic[/URL].
    I try to install once more on fresh debian etch machine. Thanks.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you connect to MySQL as follows?
    Code:
    mysql -u root -p
    If this is successful, the ISPConfig installer should have no problem as well.
     
  5. koffu

    koffu New Member

    Yes, I do. I think so. I can connect both to "mysql -u root -p" and "mysql -h localhost -u root -p" and "mysql -h myhostname.domain -u root -p". I setup the same password for all root
    accounts, but installer through installation said, that can't connect, access denied for user 'root'@'localhost'.

    in /etc/hosts I have
    127.0.0.1 localhost
    192.168.0.1 myhostname.domain
    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    hostname and hostname -f gives same result. Maybe ipv6 aliases gives it?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    df -h
    ?
     

Share This Page