some SSL problem in Mail submission.

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Jan 1, 2018.

  1. pawan

    pawan Member HowtoForge Supporter

    I am getting this error in my mail.log
    Please have a look and see how I can fix it.
    Code:
    Jan  2 04:12:26 server2 postfix/submission/smtpd[12685]: SSL_accept error from server2.mywebsolutions.co.in[69.197.135.186]: 0
    Jan  2 04:12:26 server2 postfix/submission/smtpd[12685]: warning: TLS library problem: error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert unknown ca:s3_pkt.c:1487:SSL alert number 48:
    Jan  2 04:12:26 server2 postfix/submission/smtpd[12685]: lost connection after STARTTLS from server2.mywebsolutions.co.in[69.197.135.186]
    
    Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    pawan likes this.
  3. pawan

    pawan Member HowtoForge Supporter

    Hi Till,
    I have updated the SSL certificate to let's encrypt as per the link.
    I am able to test the connection from an Magento extension Aschroder SMTP, it works fine.
    but when working with a CRON mail I am facing this issue:
    Cron Magento error:
    Code:
    Zend_Mail_Protocol_Exception: Unable to connect via TLS in /var/www/clients/client2/web200/web/lib/Zend/Mail/Protocol/Smtp.php:213
    Stack trace:
    #0 /var/www/clients/client2/web200/web/lib/Zend/Mail/Transport/Smtp.php(200): Zend_Mail_Protocol_Smtp->helo('localhost')
    #1 /var/www/clients/client2/web200/web/lib/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
    #2 /var/www/clients/client2/web200/web/lib/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #3 /var/www/clients/client2/web200/web/app/code/local/Aschroder/SMTPPro/Model/Email.php(48): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
    #4 /var/www/clients/client2/web200/web/app/code/community/Meanbee/VIPMembership/Model/Observer.php(249): Aschroder_SMTPPro_Model_Email->send()
    #5 /var/www/clients/client2/web200/web/app/code/core/Mage/Cron/Model/Observer.php(325): Meanbee_VIPMembership_Model_Observer->sendExpiryNotification(Object(Mage_Cron_Model_Schedule))
    #6 /var/www/clients/client2/web200/web/app/code/core/Mage/Cron/Model/Observer.php(72): Mage_Cron_Model_Observer->_processJob(Object(Mage_Cron_Model_Schedule), Object(Mage_Core_Model_Config_Element))
    #7 /var/www/clients/client2/web200/web/app/code/core/Mage/Core/Model/App.php(1338): Mage_Cron_Model_Observer->dispatch(Object(Varien_Event_Observer))
    #8 /var/www/clients/client2/web200/web/app/code/core/Mage/Core/Model/App.php(1317): Mage_Core_Model_App->_callObserverMethod(Object(Mage_Cron_Model_Observer), 'dispatch', Object(Varien_Event_Observer))
    #9 /var/www/clients/client2/web200/web/app/Mage.php(448): Mage_Core_Model_App->dispatchEvent('default', Array)
    #10 /var/www/clients/client2/web200/web/cron.php(76): Mage::dispatchEvent('default')
    #11 {main}
    and in smtp.php line 213 reads like this:
    Code:
      // If a TLS session is required, commence negotiation
            if ($this->_secure == 'tls') {
                $this->_send('STARTTLS');
                $this->_expect(220, 180);
                if (!stream_socket_enable_crypto($this->_socket, true, STREAM_CRYPTO_METHOD_TLS_CLIENT)) {
    
                    /**
                     * @see Zend_Mail_Protocol_Exception
                     */
                    #require_once 'Zend/Mail/Protocol/Exception.php';
                    throw new Zend_Mail_Protocol_Exception('Unable to connect via TLS');
               }
                $this->_ehlo($host);
            }
    
            $this->_startSession();
            $this->auth();
        }
    
    and in /var/log/mail.log
    Code:
    Jan  3 16:20:08 server2 postfix/submission/smtpd[23306]: lost connection after STARTTLS from server2.mywebsolutions.co.in[69.197.135.186]
    Jan  3 16:20:08 server2 postfix/submission/smtpd[23306]: disconnect from server2.mywebsolutions.co.in[69.197.135.186] ehlo=1 starttls=1 commands=2
    Can you help me resolve this?
    Thanks.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The mail server is on the same server than the Magento install? In this case better I would simply use port 25 without SSL as the connection is local only before you start to debug the Magento and Zend code.
     
  5. pawan

    pawan Member HowtoForge Supporter

    Yes I thought and tried that. but it appears that somewhere I have blocked port 25 for submission. can you give me a hint where I can re-enable it quickly else I have to spend lot of time fixing that.
     
  6. pawan

    pawan Member HowtoForge Supporter

    Hi
    Thanks Till.
    Yes with port 25, it's working absolutely fine.
     

Share This Page