Some problems with mail setup

Discussion in 'Installation/Configuration' started by sulfuric, Dec 27, 2010.

  1. sulfuric

    sulfuric ISPConfig Developer ISPConfig Developer

    I have installed ispconfig3 on centos 5.5 i386 server, I have followed this tutorial http://www.howtoforge.com/perfect-server-centos-5.5-x86_64-ispconfig-3 with the necessary changes for my distribution i386.

    In the ispconfig 3 monitor all are green but i can't setup an email account with outlook,

    my first problem, I can't telnet 25 port with an other machine, only in localhost

    telnet www.lowcoxxxxxx.es 110
    Trying 82.194.76.xx...
    Connected to www.lowcoxxxxxxx.es.
    Escape character is '^]'.
    +OK Dovecot ready.
    quit
    +OK Logging out
    Connection closed by foreign host.

    telnet www.lowcoxxxxxx.es 25
    Trying 82.194.76.xx...
    telnet: Unable to connect to remote host: Connection refused

    second problem, this error in secure log

    Dec 27 12:13:58 hsle-141 dovecot-auth: pam_unix(dovecot:auth): check pass; user unknown
    Dec 27 12:13:58 hsle-141 dovecot-auth: pam_unix(dovecot:auth): authentication failure; logname= uid=0 euid=0 tty=dovecot [email protected] rhost=81.202.207.xx
    Dec 27 12:13:58 hsle-141 dovecot-auth: pam_succeed_if(dovecot:auth): error retrieving information about user [email protected]

    thanks
     
  2. sulfuric

    sulfuric ISPConfig Developer ISPConfig Developer

    advance

    Now i can connect to port 25 can recive mails can send with squirremail, but can't send via smtp

    I think that the problem it's on /etc/postfix/sasl/smtpd.conf it's empty and /etc/postfix/sasl folder doesn't exists

    ¿ some help ? thanks in advance
     
    Last edited: Dec 27, 2010
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Your system uses authentication by dovecot and not sasl. So the files are not nescessary on your server.

    Are you sure vthat you installed a dovecot binary that supports mysql? Because the line "dovecot-auth: pam_unix" indicates that dovecot is using pam and not mysql to authenticate.
     
  4. sulfuric

    sulfuric ISPConfig Developer ISPConfig Developer

    thanks for your reply

    I install dovecot follow the last comment of tutorial page http://www.howtoforge.com/perfect-server-centos-5.5-x86_64-ispconfig-3-p4

    adding to my repository

    [atrpms]
    name=Red Hat Enterprise Linux 5 - i386 - ATrpms
    baseurl=http://dl.atrpms.net/el5-i386/atrpms/stable
    failovermethod=priority
    exclude=dovecot-2*
    includepkgs=dovecot dovecot-sieve

    #
    # requires stable
    #
    [atrpms-testing]
    name=Red Hat Enterprise Linux 5 - i386 - ATrpms testing
    baseurl=http://dl.atrpms.net/el5-i386/atrpms/testing
    failovermethod=priority
    enabled=1
    exclude=dovecot-2*
    includepkgs=dovecot dovecot-sieve

    #
    # requires stable and testing
    #
    [atrpms-bleeding]
    name=Red Hat Enterprise Linux 5 - i386 - ATrpms bleeding

    how can i test if my dovecot support mysql, or change authentication from pam to mysql ?

    thanks
     
  5. sulfuric

    sulfuric ISPConfig Developer ISPConfig Developer

    a little more

    I think that mysql support is installed, i don't have errors in logs and the configuration file /etc/dovecot-sql.conf it's ok

    driver = mysql
    connect = host=localhost dbname=dbispconfig user=ispconfig password=73a29d9a6e99472fb89f43xxxxxxxxxxx
    default_pass_scheme = CRYPT

    password_query = SELECT password FROM mail_user WHERE email = '%u' AND disable%Ls = 'n'
    user_query = SELECT email as user, maildir as home, CONCAT('maildir:', maildir, '/Maildir') as mail, uid, gid, CONCAT('maildir:storage=', floor(quota/1024)) AS quota, CONCA$

    really ???

    the problem it's on dovecot conf file i'm sure, when i installed ispconfig3 the dovecot package wasn't on line and I installed ispconfig without this for work with web server and then install mail server.

    that's part of my dovecot.conf

    passdb sql {
    # Path for SQL configuration file, see doc/dovecot-sql-example.conf
    args = /etc/dovecot-sql.conf
    }

    is it ok ??

    disable_plaintext_auth = no (or yes for mysql auth)
     
  6. sulfuric

    sulfuric ISPConfig Developer ISPConfig Developer

    A little step for humanity, a big step for a man

    I little step, I comment

    passdb pam{

    in dovecot conf and then this is my new error ...

    connect from 81.202.207.70.dyn.user.ono.com[81.202.207.70]
    Dec 29 17:27:46 hsle-141 postfix/smtpd[25557]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Dec 29 17:27:46 hsle-141 postfix/smtpd[25557]: warning: 81.202.207.70.dyn.user.ono.com[81.202.207.70]: SASL LOGIN authentication failed: generic failure
    Dec 29 17:27:46 hsle-141 postfix/smtpd[25557]: lost connection after AUTH from 81.202.207.70.dyn.user.ono.com[81.202.207.70]
    Dec 29 17:27:46 hsle-141 postfix/smtpd[25557]: disconnect from 81.202.207.70.dyn.user.ono.com[81.202.207.70]

    how can I setup my server for login without SASLAUTH DAEMON, if i shut down and other error in maillog appear for inform that saslauthd is off

    thanks
     
  7. sulfuric

    sulfuric ISPConfig Developer ISPConfig Developer

    Solved

    Chaplin's error :p solved,

    I comment out this lines and all works fine

    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth

    in main.cf

    happy new year !!!
     

Share This Page