some problem after installing perfect server setup for centos 5.3 and ispconfig 3

Discussion in 'Installation/Configuration' started by cobro, Jul 2, 2009.

  1. cobro

    cobro New Member

    i did fallow this great server setup The Perfect Server - CentOS 5.2 [ISPConfig 3]

    but i have don some thing wrong my mail is not working right this is what i get if i try to send e-mail to my e-mail server on my new box

    --> The following message to <name@domain.com> was undeliverable.
    The reason for the problem:
    5.1.0 - Unknown address error 550-'relay not permitted' <---

    and also one thing if i go in ispconfig admin panel and go to monitor and then show ispc cron-log this is what is shows me

    ---> Error: configuration file /etc/getmail/*.conf does not exist <---

    and then final fail2ban is not installed but i did installed it and ispconfig tells me that is it not installed

    --->fail2ban is not installed at this server.
    See more (for debian) here... <---

    and one more thing i cannot connect to my webmail ?

    ---> Forbidden

    You don't have permission to access /webmail on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. <---

    i think my ispconfig is running ok so this is not that but the packages that i did installed i have done them wrong but if anyone could help me that would be well appreciated :)
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please make sure that the MX record for your domain is pointing to the correct server. You can check that with
    Code:
    dig mx yourdomain.com
     
  3. cobro

    cobro New Member

    I have seen what the problem was it was the authentication password that i needed on my e-mail client and i filled that info and every thing worked but one thing i can not send e-mail from my mail server to another mail server ? what could be the problem i can wright i messages and it sends but i do not receive it on my other mail server witch is not on my server..Thanks for all the help

    and also webmail and phpmyadmin dose not work ? when i try to connect to it trough my browser ? any idea ?
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  5. cobro

    cobro New Member

    thank you for the last response i did send them e-mail about taking my server off list i only got one listed...

    but what can i do if i stumble on another problem regarding pointing my browser to webmail or phpmyadmin and it dose not work ?
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What exactly is the problem?
     
  7. cobro

    cobro New Member

    when i point my web browser to www.domain.com/webmail or phpmyadmin

    this is what i get in return

    Forbidden

    You don't have permission to access /webmail on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    Forbidden

    You don't have permission to access /phpmyadmin on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
     
  8. Stown

    Stown ISPConfig Developer ISPConfig Developer

    I had a sort of same problem with my mail in the beginning, this is only on setups with centos 5.3 i think

    If you install postfix with 'yum install postfix' it installs postfix without mysql and you need the with mysql option. This is a problem of the default repo's of centOS.

    You need thisone:
    Installed Packages
    Name : postfix
    Arch : i386
    Epoch : 2
    Version : 2.3.3
    Release : 2.el5.centos.mysql_pgsql
    Size : 8.3 M
    Repo : installed
    Summary : Postfix Mail Transport Agent
    URL : http://www.postfix.org
    License : IBM Public License
    Description: Postfix is a Mail Transport Agent (MTA), supporting LDAP, SMTP AUTH

    If this package is also not in the rpmforge repo than you have to download the .rpm from a rpm search site and install it
     
  9. cobro

    cobro New Member

    this is what i get

    SORBS-DUHL Listed LISTED Dynamic IP Addresses See: Detail

    Return codes were: 127.0.0.10 3505 1969

     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This means that your server is located on a dynamic IP. Most mailservers worwide do not accept emails from a server that is hosted on a dynamic IP address. You will either have to move your server to a datacenter witha fixed IP or you will have to setup postfix to relay all emails trogh an external mail server.
     
  11. escu

    escu New Member

    How about that fail2ban problem? My server also reports it as not installed, although I have installed it. CentOS 5.3 here, too.

    Later edit: sorry for this post, I found the answer: fail2ban must be configured separately.
    I added the following for pure-ftpd and activated also the sshd in jail file
    Code:
    [pure-ftpd-iptables]
    
    enabled  = true
    filter   = pure-ftpd
    action   = iptables[name=PureFTP, port=ftp, protocol=tcp]
               sendmail-whois[name=PureFTP, dest=root@mydomain.tld, sender=fail2ban@mydomain.tld]
    logpath  = /var/log/pureftpd.log
    maxretry = 5
    Hope it is correct; I'm waiting to see some results, as there are already some guys trying to connect by ftp :)
     
    Last edited: Jul 16, 2009
  12. Stown

    Stown ISPConfig Developer ISPConfig Developer

    How do you mean fail2ban must configured seperately? What do i have to configure to make it work with ispconfig? I have centos 5.3 too..
     
  13. escu

    escu New Member

    Simple: after everything is working, go to /etc/fail2ban

    Here, open jail.conf in your favorite editor. Find the entry:

    Code:
    [ssh-iptables]
    
    enabled  = false
    filter   = sshd
    action   = iptables[name=SSH, port=ssh, protocol=tcp]
               sendmail-whois[name=SSH, dest=root@server1.icsys.ro, sender=fail2ban@icsys.ro]
    logpath  = /var/log/sshd.log
    maxretry = 5
    
    and change enable = false to enable = true for SSH. Do the same for the other services you wish to protect, as well. Also add the entry I posted in the previous message, for pure-ftpd.

    After saving the file, give the command service fail2ban restart then check the logs in IPConfig.
     

Share This Page