Some one help me with my website access

Discussion in 'HOWTO-Related Questions' started by sidbyron, Sep 8, 2011.

  1. sidbyron

    sidbyron Member

    Hi,

    Someone knows why i can't access to my created website with ispconfig.

    Look mydomainname is the samen that hostname.

    First I had problems with postfix but I fix it deleting hostname from main.cf but when I want to access to the website I can't access only i can see the page of the apache "It Works"

    Someone knows wich is the configuration???:confused:
     
  2. mentes

    mentes New Member

    Did you create a 'website' in 'sites' ?

    Did you create a DNS Zone?
     
  3. sidbyron

    sidbyron Member

    yes

    A goandfixsvr.com. 85.17.236.154 0
    A mail 85.17.236.154 0
    A NS1 85.17.236.154 0
    A NS2 85.17.236.154 0
    A www 85.17.236.154 0
    CNAME pop3.goandfixsvr.com mail.goandfixsvr.com 0
    MX goandfixsvr.com. mail.goandfixsvr.com. 10
    NS goandfixsvr.com. NS1.GOANDFIXSVR.COM. 0
    NS goandfixsvr.com. NS2.GOANDFIXSVR.COM. 0

    but when I put goandfixsvr.com the server load me /var/www

    this is the url of ISP config website configuration "/var/www/clients/client1/web3/web"
     
  4. mentes

    mentes New Member

    Do you have something in Monitor -> Show Jobqueue?

    Do you have this file /etc/apache2/sites-enabled/goandfixsvr.com.vhost ?
     
  5. sidbyron

    sidbyron Member

    No i don't have any in Show Jobqueque.

    And i have my goandfixsvr.com.vhost.

    This is the configuration:

    <Directory /var/www/goandfixsvr.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/goandfixsvr.com/web

    ServerName goandfixsvr.com
    ServerAlias *.goandfixsvr.com
    ServerAdmin [email protected]

    ErrorLog /var/log/ispconfig/httpd/goandfixsvr.com/error.log


    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/goandfixsvr.com/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web3/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_value sendmail_path "/usr/sbin/sendmail -t -i [email protected]"
    php_admin_value upload_tmp_dir /var/www/clients/client1/web3/tmp
    php_admin_value session.save_path /var/www/clients/client1/web3/tmp
    # PHPIniDir /var/www/conf/web3
    php_admin_value open_basedir /var/www/clients/client1/web3/web:/var/www/clients/client1/web$
    </VirtualHost>

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^goandfixsvr.com [NC]
    RewriteRule ^/(.*)$ http://goandfix.com/goandfixsvr.com/web/$1 [L]

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web3 client1
    </IfModule>

    <IfModule mod_dav_fs.c>
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN
    # WEBDAV END
    </IfModule>

    I have made some changes and i put a redirection "L" to "http://goandfixsvr.com/goandfixsvr.com/web/" and i use ModPHP and in autosubdomain I Have " * ". WELL!! when I enter in www.goandfixsvr.com I see the website but if i want to get in goandfix.com I only see "it Works" o "/var/www" Directory
     
  6. mentes

    mentes New Member

    Remove that redirection, you don't need it.

    You should have a symlink in /var/www

    /var/www/goandfixsvr.com -> /var/www/clients/client1/web3/web

    If you have /var/www/clients/client1/web3/web, create the symlink

    ln -s /var/www/clients/client1/web3/web /var/www/goandfixsvr.com
     
  7. sidbyron

    sidbyron Member

    Ok I Do it and I have the same problem i can enter in www.goandfixsvr.com but in goandfixsvr.com I only see "It Works" or "Directory Index (Because I rename index.hml)"

    Probably I think that the problem is my domain name is same that my hostname but i don't know if there is any modification how "postfix" configuration like this http://www.howtoforge.com/forums/showthread.php?t=49586 or probably i have to add a DNS zone for the page without "www".

    :confused:
     
  8. mentes

    mentes New Member

    Your problem is, you don't have /var/www/clients

    Did you removed it ?

    Where you put Joomla's installer ?
     
  9. sidbyron

    sidbyron Member

    No I don't.

    My Joomla installer is in the goandfixsvr.com web folder.
     
  10. mentes

    mentes New Member

    Which is the absolute path of 'goandfixsvr.com web folder' ?

    Which linux version are you using ?
     
  11. sidbyron

    sidbyron Member

    Temporaly I Fix It I have created a DNS CNAME register that goandfixvsr.com go to www.goandfixsvr.com but tha is incorrect right?
     
  12. mentes

    mentes New Member

    You don't need CNAME, redirect, ... You need a directory /var/www/clients if you don't have this, something is wrong.

    I think you modified a lot of things, the best way is start again with a clean installation following The Perfect Server howto carefully.
     
  13. sidbyron

    sidbyron Member

    mmmm I don't think so because I have directory /var/www/clients
     
  14. mentes

    mentes New Member

    I didn't see when I went to goandfixsvr.com but I believe you.

    Paste here your DNS records.
     
  15. sidbyron

    sidbyron Member

    A goandfixsvr.com. 85.17.236.154 0
    A mail 85.17.236.154 0
    A NS1 85.17.236.154 0
    A NS2 85.17.236.154 0
    A www 85.17.236.154 0
    CNAME pop3.goandfixsvr.com mail.goandfixsvr.com 0
    MX goandfixsvr.com. mail.goandfixsvr.com. 10
    NS goandfixsvr.com. NS1.GOANDFIXSVR.COM. 0
    NS goandfixsvr.com. NS2.GOANDFIXSVR.COM. 0
     
  16. mentes

    mentes New Member

    Seems right.

    Do you have something inside this /var/www/clients/client1/web3/web ?
     
  17. sidbyron

    sidbyron Member

    sure the joomla instalation
     
  18. mentes

    mentes New Member

    What do you have in /etc/hostname and /etc/hosts ?
     
  19. sidbyron

    sidbyron Member

    in the file hosts:


    127.0.0.1 localhost
    85.17.236.154 goandfixsvr.com goandfixsvr

    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    and hostname file is:

    goandfixsvr.com
     
  20. mentes

    mentes New Member

    - Edit /etc/hosts and replace this line: 85.17.236.154 goandfixsvr.com goandfixsvr

    85.17.236.154 whatever.goandfixsvr.com whatever

    - Edit /etc/hostname and replace: goandfixsvr.com

    whatever.goandfixsvr.com

    Reboot whole server.

    * All whatever should be the same.
     

Share This Page