some more mydns problems

Discussion in 'Installation/Configuration' started by sethos, Jul 15, 2011.

  1. sethos

    sethos New Member

    All-

    I've searched and searched and not found a solution to this, some very close but not it.

    DNS or myDNS not working.please help, thanks in advance.

    my server

    ISPConfig 3..0.3.3 upgraded from 3.0.3.2

    centos 5.3 for driver reasons but yum updated -kernel and -kernel-headers

    follwed this howto The Perfect Server - CentOS 5.3 x86_64 [ISPConfig 3] | HowtoForge - Linux Howtos and Tutorials

    output from command progs
    -----------------------------------DIG---------------------------------------

    dig @localhost mymain.tld

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5 <<>> @localhost mymain.com
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 22829
    ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mymain.com. IN A

    ;; Query time: 1 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Jul 15 14:40:04 2011
    ;; MSG SIZE rcvd: 28

    why REFUSED??


    ------------------------NETSTAT------------------

    # netstat -tap | grep dns
    tcp 0 0 ns2.mydomain.com:domain *:* LISTEN 2930/mydns
    tcp 0 0 ns1.mydomain.com:domain *:* LISTEN 2930/mydns
    tcp 0 0 db.mydomain.com:domain *:* LISTEN 2930/mydns
    tcp 0 0 mail.mydomain.com:domain *:* LISTEN 2930/mydns
    tcp 0 0 mydomain.com:domain *:* LISTEN 2930/mydns
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 2930/mydns
    tcp 0 0 localhost6.localdoma:domain *:* LISTEN 2930/mydns


    so mydns is running bind is removed

    --------------------------MYDNS---------------


    # mydns
    mydns[13626]: bind (TCP): 127.0.0.1:53: Address already in use

    But it is by mydns

    more mydns

    mydnsexport
    $TTL 86400
    ; Zone: mydomain.com. (#11)
    ; Created by "mydnsexport"
    ; Fri Jul 15 15:07:05 2011
    $ORIGIN mydomain.com.

    @ IN SOA ns1.mydomain.com. admin.mydomain.com. (
    2011071501 ; Serial
    28800 ; Refresh
    7200 ; Retry
    604800 ; Expire
    86400 ) ; Minimum

    mail 86400 IN A 72.27.226.82
    mydomain.com. 86400 IN A 72.27.226.82
    mydomain.com. 86400 IN MX 10 mail.mydomain.com.
    mydomain.com. 86400 IN NS ns1.mydomain.com.
    mydomain.com. 86400 IN NS ns2.mydomain.com.
    www 86400 IN A 72.27.226.82


    any help would be much appreciated,
    sethos
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to restart the whole server. It might be that mydns hangs and is not picking up the domain changes. Another option is that mydns uses the wrong database. Please check in mydns configuration file if it connects to the ispconfig database.
     
  3. sethos

    sethos New Member

    thanks for the input.

    thanks for the tips,

    reboot no joy
    checked the mydns db setting w/ this.

    mydnscheck -v
    mydnscheck: connected to localhost, database "dbispconfig"
    mydnscheck: mydomain.com.: 6 resource records.i did the netstat n-tap again but got the same results.

    -sethos
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    getenforce
    ?
     
  5. sethos

    sethos New Member

    getenforce
    Disabled



    thanks
     
  6. falko

    falko Super Moderator ISPConfig Developer

    That's ok.

    I'm not sure if it is related to your problem, but you didn't create any A records for your nameservers (ns1.mydomain.com and ns2.mydomain.com).
     
  7. sethos

    sethos New Member

    switched to bind

    CHROOTED of course and although more comp li cated ive found some nice howtos

    what makes the pri.mydomain files show up and how can i edit them and where they show up?
     
  8. sethos

    sethos New Member

    bind issues

    I followed a guide to install a chrooted bind server but when i add

    include "/var/named/chroot/var/named/named.local";

    that line it wont restart iget these errors:

    named: /var/named/chroot/var/named/named.local:1: unknown option 'zone'
    Jul 19 14:44:52 sumhap named: /var/named/chroot/var/named/named.local:6: unknown option 'zone'
     
  9. falko

    falko Super Moderator ISPConfig Developer

    What do you have in /var/named/chroot/var/named/named.local?
     
  10. sethos

    sethos New Member

    at named.local
    zone "skyler-grrl.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/chroot/var/named//pri.skyler-grrl.com";
    };
    zone "nordmeyer.co" {
    type master;
    allow-transfer {none;};
    file "/var/named/chroot/var/named/data/nordmeyer.co.zone";
    };

    both are sites of mine the 2nd one i changed the path and name of the pri file
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Is it possible that you have Windows linebreaks instead of Unix linebreaks in the file?
     
  12. sethos

    sethos New Member

    not it. its a unix file.

    i moved the "include" around and it was finally ok.

    now when a remote client queries one of my domains. they getan error like this


    Jul 21 14:17:26 sumhap named[24941]: client 66.249.67.44#39117: query 'ns1.sumhap.com/A/IN' denied
    Jul 21 14:17:30 sumhap named[24941]: client 66.249.67.184#50460: query 'ns2.sumhap.com/A/IN' denied

    any ideas? thanks for all your help,
    sSetho
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Can you post your named.conf?
     

Share This Page