Some issues after Update to 2.2.5

Discussion in 'Installation/Configuration' started by virtualweb, Jul 18, 2006.

  1. virtualweb

    virtualweb New Member

    Hi,

    after the update i figured out some issues:

    1) in "Management - Server - Services - Monitoring" some items are listed twice (web:80).

    2) how does suPHP work within ISPConfig? do we have to install suPHP separately, are there any settings in ISPConfig? Haven't found something about this.

    in case of the cms "joomla" all files are owned by webx_office : webx. those files must be writable by www-data. when changing the permissions to www-data, the user can't edit the files via ftp anymore. when the user installs new components in joomla the files are owned by www-data.

    Are there any Manuels or Tipps about suPHP for usage with ISPConfig?

    Regards,
    Alfons
     
    Last edited: Jul 18, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Well check that.

    There are no manuals yet.

    1) You will have to install suphp on your server, for exampla as described here:

    http://www.howtoforge.com/apache2_suphp_php4_php5

    2) Enable SuPHP by changing the line:
    Code:
    $go_info["server"]["apache2_php"] = 'filter,addtype,engine'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled

    to:
    Code:
    $go_info["server"]["apache2_php"] = 'suphp'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled
    in the file /home/admispconfig/ispconfig/lib/config.inc.php
     
  3. virtualweb

    virtualweb New Member

    Thank your for the quick reply.

    I followed the documentation you suggested, but am not sure, if it is the correct way:

    after installing suPHP and restarting the webserver says:
    All commands which contains "php" are marked as an error, i found following reason for it:

    Code:
    suphp doesn't support the php_flag, php_value, php_admin_value, and 
    php_admin_flag directives.  Primarily because mod_php is no longer 
    loaded after suphp is installed.  Use suPHP_ConfigPath in each vHost 
    and setup individual php.ini files.
    As far as i know those directives are generated and used by ISPConfig, so do i really have to setup individual php.ini's for each vhost?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No.

    Have you changed the line in config.inc.php?

    After you switched your server to suphp, edit one of your websites (change e.g. quota or something else) and hit save so you Vhost_ispconfig.conf gets rewritten with the SuPHP setup.
     
  5. virtualweb

    virtualweb New Member

    OK that works, as you described it.

    Thanks very much!
     
  6. Ben

    Ben ISPConfig Developer ISPConfig Developer

    But don't forget that suPHP needs more ressources on your server in cases of heavy access than mod_php
     

Share This Page