some dns or vhosts error I can't see

Discussion in 'Installation/Configuration' started by stormica2, May 2, 2011.

  1. stormica2

    stormica2 New Member

    Hi All,

    This is my first crack at ISPConfig, and so far I'm loving it. I have only a small problem that I can't seem to figure out.

    I'm sure that what's happening is that I'm too close to this, and have been staring at this too look so I can't see what's wrong, but here it goes:

    The problem is that is displaying a squirrelmail login screen. There is webcontent that should be shown, and it shows properly if you leave the www off, i.e

    I have tried www and in the zone file, and both give the same result.

    This is literally the last thing that needs to be fixed before the server can go live, and I've been banging my head on this for the last couple of hours.

    Here's the zone file (obviously with and 174.3.x.x substituted in for the real info)

    $TTL 3600
    @ IN SOA (
    2011050114 ; serial, todays date + todays serial #
    3600 ; refresh, seconds
    1800 ; retry, seconds
    604800 ; expire, seconds
    3600 ) ; minimum, seconds
    ; 3600 A 174.3.x.x 3600 A 174.3.x.x CNAME 3600 A 174.3.x.x CNAME CNAME CNAME 3600 A 174.3.x.x 3600 A 174.3.x.x MX 10 NS CNAME 3600 A 174.3.x.x

    edit: I've also tried the www entry as a CNAME and an A record, neither seems to be working. the CNAME was set to

    This is my php open_basedir:

    I have followed the following two tutorials to build this server:

    There is no subdomain configured for www, which is the same as the other 2 domains I have set up, and they seem to be behaving themselves.

    Of note, I don't know if this makes a difference:
    I have set up the main domain for this server (named as a client in ISPConfig and configured all of it's details this way. Because everything else seems to work, I doubt it's a problem, but I thought I'd mention it.

    Any help seeing the forest for the trees would be greatly appreciated.

    Last edited: May 2, 2011
  2. stormica2

    stormica2 New Member

    Replying for posterity:

    A friend found the problem for me.

    the vhost file for the domain didn't have the "ServerAlias" entry required for the www to work correctly.

Share This Page