[SOLVED] X-Original-To missing with newly setup server with rspamd

Discussion in 'ISPConfig 3 Priority Support' started by KoS, Sep 15, 2019.

  1. KoS

    KoS Member HowtoForge Supporter

    Thanks to the newly released rspamd support in ISPconfig 3.1.15 I have set up a new (multi-)server. I noticed that I am missing the X-Original-To header in the emails, whereas I rely on it for my sieve filtering. I am using Ubuntu 18.04 LTS and the configuration of postfix is the default one, with the modifications by ISPconfig. Postconf shows that enable_original_recipient is set to yes. I have no idea why the X-Original-To lines are missing. Is this related to rspamd or to some ISPconfig specific settings?

    Kind regards
    KoS
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. KoS

    KoS Member HowtoForge Supporter

    I thought the same, but didn't find any option specific to the X-Original-To header being removed by rspamd :-(
    I tried to disable the spamfilter for the domain and mailboxes via ISPconfig to see if the header would be there if the mails are not "touched" by rspamd, but the mail still showed up in the log/history of rspamd and was scanned. Isn't the spamfilter functionality in ISPconfig working for rspamd?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There is and was never an option to disable the spamfilter in ISPConfig, the spamfilter is always on, no matter if you use amavis or rspamd because the spamfilter does also Dkim signing and antivirus scanning. If you do not set it for a domain or mailbox, then the defaults apply, which are chioosen quite high so the spam is not actually filtered. But this does not mean that the email does not pass the filter software.
     
  5. KoS

    KoS Member HowtoForge Supporter

    Thanks Till, sorry for my misunderstanding, I always thought that the "- not enabled -" dropdown option for the Spamfilter means it is not enabled and not scanning the mails.

    Do you see on your rspamd-enabled ISPconfig installation the X-Original-To header being set?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I don't use X-Original-To on my systems for filtering. I checked an Amavis based and a Rspamd based ISPConfig Debian system and this header is not set on any of them.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    @Croydon sent me just a note that this header is probably only set when the email is delivered trough an alias, so maybe the mail you checked has not been delivered through an alias and therefore the header is not set.
     
  8. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    I've dig a bit into the header and it is highly unreliable:
    http://postfix.1071664.n5.nabble.com/virtual-alias-maps-and-X-Original-To-td9124.html
    Maybe you added a custom map with regex rules etc. to postfix that got removed on ISPConfig update.
     
  9. KoS

    KoS Member HowtoForge Supporter

    Thanks Croydon, I haven't seen your message until now when I was digging into that issue again and found the solution.

    I have finally found the root cause: in the postfix master.cf the dovecot service was added with the "flags=DRhu" whereas on my old mail-server it is "flags=DROhu" whereas the O flag is for adding the X-Original-To header. I do not remember that I had ever added that manually on my old installation, but that is already a few years ago when it was original set up :-(

    As I have modified it now on the new server, I assume ISPconfig will overwrite it in case I select the "re-configure" service?

    Thank you all! Now I am ready to migrate the next server :)
     

Share This Page