SOLVED - Should Python 2.7 (Debian 9 distribution) been updated to 3.x right now?

Discussion in 'Installation/Configuration' started by coffeemug, Jan 24, 2019.

  1. coffeemug

    coffeemug New Member HowtoForge Supporter

    Root-Server, 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64; 8GB RAM; 320GB HDD1, 2 CPU's

    Code:
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] No ISPConfig found.
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 7.0.33-0+deb9u1
    
    ##### PORT CHECK #####
    
    [WARN] Port 993 (IMAP server SSL) seems NOT to be listening
    [WARN] Port 995 (POP3 server SSL) seems NOT to be listening
    [WARN] Port 21 (FTP server) seems NOT to be listening
    
    ##### MAIL SERVER CHECK #####
    
    
    ##### RUNNING SERVER PROCESSES #####
    
    [INFO] I found the following web server(s):
        Apache 2 (PID 1337)
    [INFO] I found the following mail server(s):
        Postfix (PID 28481)
    [INFO] I found the following pop3 server(s):
        Dovecot (PID 18531)
    [INFO] I found the following imap server(s):
        Dovecot (PID 18531)
    [WARN] I could not determine which ftp server is running.
    
    ##### LISTENING PORTS #####
    (only        ()
    Local        (Address)
    [localhost]:10023        (3297/postgrey)
    [localhost]:10024        (3906/amavisd-new)
    [localhost]:11211        (11890/memcached)
    [anywhere]:587        (28481/master)
    [anywhere]:110        (18531/dovecot)
    [anywhere]:143        (18531/dovecot)
    [anywhere]:465        (28481/master)
    [anywhere]:22        (785/sshd)
    [anywhere]:25        (28481/master)
    *:*:*:*::*:10023        (3297/postgrey)
    *:*:*:*::*:10024        (3906/amavisd-new)
    *:*:*:*::*:3306        (28759/mysqld)
    *:*:*:*::*:587        (28481/master)
    [localhost]10        (18531/dovecot)
    [localhost]43        (18531/dovecot)
    *:*:*:*::*:80        (1337/apache2)
    *:*:*:*::*:465        (28481/master)
    *:*:*:*::*:22        (785/sshd)
    *:*:*:*::*:25        (28481/master)
    *:*:*:*::*:443        (1337/apache2)
    
    
    
    
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination   
    Following the step-by-step instructions "The Perfect Server - Debian 9 (Stretch) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1"

    Executing point 11 (page 2)

    Code:
    Installing Python packages...
    Had a problem while installing Python packages.
    
    pip prints the following errors:
    =====================================================
    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
    

    Should I update Python now and if yes, how?
     
    Last edited: Jan 24, 2019
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    No.
    I think that warning comes from PIP, not Debian. Let's Encrypt folks need to update their certbot to use Python 3 before January 1st, 2020.
    Your Debian already has Python 3.x, it's just that so many utilities still use Python 2 that Debian has been forced to include also Python 2.7 for them.
     
    coffeemug likes this.
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I read from https://certbot.eff.org/lets-encrypt/debianstretch-apache
    that for Apache and Debian 9 Stretch:
    Should the Perfect Server Guide for Stretch reflect this?
     
    coffeemug likes this.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I've changed the perfect setup already yesterday to not use the certbot package from Debian standard repo anymore, instead it uses now certbot-auto to install the latest certbot version. I found it easier to use certbot-auto and let certbot deal with installing dependencies than explaining to users how to enable backports repo before they are able to install certbot.
     
    coffeemug likes this.
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    coffeemug likes this.
  6. coffeemug

    coffeemug New Member HowtoForge Supporter

    Till, thanks a lot. To be sure, I will start from scratch.

    I would like to recommend you something for your step-by-step instruction. Which would have helped me a lot.
    A lot of people are dealing with
    Code:
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_US.utf8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    because there computer is set in another language which SSH forwards to and tries to use on the server, but the server doesn't have it installed yet.

    So I did several things:
    1. Comment out "SendEnv LANG LC" in the ssh_config on my computer
    Code:
    nano /etc/ssh/ssh_config
    2. installed the language from the computer on the server (in my case German) and afterwards a reboot.
    Code:
    locale-gen
    reboot
    Now the perl messages are gone for good. And still I don't feel sure with it. Please let me know, if there is a smoother way
     
    till likes this.
  7. coffeemug

    coffeemug New Member HowtoForge Supporter

    Now I retried again and the perl message kept apearing.
    Now I did that:
    Code:
    Localhostfehler beheben:
    export LANGUAGE=en_US.UTF-8
    export LANG=en_US.UTF-8
    export LC_ALL=en_US.UTF-8
    locale-gen en_US.UTF-8
    dpkg-reconfigure locales
    de & us auswählen
    reboot
    and now the perl messages are no more apearing
     
    till likes this.

Share This Page