[SOLVED] Server monitoring NOT being updated for a new server

Discussion in 'ISPConfig 3 Priority Support' started by KoS, Sep 30, 2019.

  1. KoS

    KoS Member HowtoForge Supporter

    I have added a new server to my multi-server setup, but the details in the monitoring tab for this server are NOT being updated (see the screenshot below, the server is running for >12 hours). The server is configured ONLY as mail server and I can successfully add new mailboxes etc... so the server IS connecting to master and the job queue is being normally worked on.

    Where shall I start investigated that issue? in the /var/log/ispconfig files on that server I don't see any issues. May it be related to permission issues for that multiserver user in the DB?

    Kind regards

  2. till

    till Super Moderator Staff Member ISPConfig Developer


    and try to login from slave server to master by using the mysql dbmaster login details from ISPCOnfig config.inc.php file.

    Yes, thats the most likely reason.
  3. KoS

    KoS Member HowtoForge Supporter

    Dear Till

    Thank you very much.

    I tried connecting to the masters sql server from slave and it worked as expected.

    Afterwards I followed the instructions on the page:
    turned off the cron job, enabled debug mode, execute the server.php manually. the output on the command line was the same as i can see now in the "Show System-Log".
    Should I look for something specific in the log? I don't see any suspicous, nor any warnings or errors. I see that there are two entries "Replicated from master", but no "update" that would be pushed back to the server.

    I have compared all the privileges in MySQL for that specific user on the master server with the user of another slave server (including table & column specific privileges) and couldn't find a difference :-(

    Any idea what to check next?

    Kind regards
  4. KoS

    KoS Member HowtoForge Supporter

    I have had enabled back the cron job, but didn't change anything else. Now after a while I see suddenly the following change: upload_2019-9-30_23-30-53.png

    --> looks weird without the whitespace and no details about the OS.
    In the systemlog I only see the "remove lock" entries, but nothing additional from that slave..
  5. KoS

    KoS Member HowtoForge Supporter

    Again, I didn't do ANY change, but now everything seems to works as expected:

    weird :-(

    Attached Files:

Share This Page