[solved] roundcube ispconfig3_account soap_validate_cert

Discussion in 'Plugins/Modules/Addons' started by electronico_nc, Nov 28, 2018.

  1. Hi all,
    Just installed the ISPConfig roundcube plugin from GIT.
    Noticed a new parameter in
    $config['soap_validate_cert'] = true;
    I have to set it to false to make the plugin working.
    Set it to true shows : SOAP error : could not connect to host in Roundcube.
    Could you please explain what is this parameter trying to do ?
    Thanks in advance !
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Without consulting the documentation to verify, that setting should configure it to require a valid ssl certificate or not. You are probably using a self-signed certificate; if you install a certificate from a known CA (eg. let's encrypt is common for this) you could probably leave that at true and it would work.
    electronico_nc likes this.
  3. Thanks @Jesse Norell for the answer.
    There is well an applied LE certificate for the ISPConfig dashboard.
    That's well related to LE certificate : server FQDN has be used (FQDN used to make LE certificate) instead of IP address
    // $config['soap_url'] = 'https://www.xxx.yyy.zzz:8080/remote/';
    $config['soap_url'] = 'https://host.domain.tld:8080/remote/';
    $config['soap_validate_cert'] = true;
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

Share This Page