[SOLVED] Postfix mail returns to sender only for one account

Discussion in 'ISPConfig 3 Priority Support' started by ktownmods, Feb 25, 2019.

  1. ktownmods

    ktownmods Member HowtoForge Supporter

    Hey,

    if i send an email from gmail.com to [email protected] i get the message:

    Code:
    This is the mail system at host mail.mydomain.de.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <[email protected]> (expanded from <[email protected]>): mail for
        mail.mydomain.de loops back to myself
    
    
    if i send it to another emailadress on my system it works

    Maillog:

    Code:
    Feb 25 14:50:22 mail postfix/smtpd[15175]: connect from mail-it1-f169.google.com[209.85.166.169]
    Feb 25 14:50:23 mail postfix/smtpd[15175]: NOQUEUE: filter: RCPT from mail-it1-f169.google.com[209.85.166.169]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail-it1-f169.google.com>
    Feb 25 14:50:23 mail postfix/smtpd[15175]: NOQUEUE: filter: RCPT from mail-it1-f169.google.com[209.85.166.169]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail-it1-f169.google.com>
    Feb 25 14:50:23 mail postfix/smtpd[15175]: warning: 169.166.85.209.zen.spamhaus.org: RBL lookup error: Host or domain name not found. Name service error for name=169.166.85.209.zen.spamhaus.org type=A: Host not found, try again
    Feb 25 14:50:23 mail postfix/smtpd[15175]: 1FD786A03FD: client=mail-it1-f169.google.com[209.85.166.169]
    Feb 25 14:50:23 mail postfix/cleanup[16040]: 1FD786A03FD: message-id=<[email protected]om>
    Feb 25 14:50:23 mail postfix/qmgr[15149]: 1FD786A03FD: from=<[email protected]>, size=2515, nrcpt=1 (queue active)
    Feb 25 14:50:23 mail postfix/smtpd[15175]: disconnect from mail-it1-f169.google.com[209.85.166.169] ehlo=2 starttls=1 mail=1 rcpt=1 data=1 quit=1 commands=7
    Feb 25 14:50:23 mail postfix/smtpd[16044]: connect from localhost.localdomain[127.0.0.1]
    Feb 25 14:50:23 mail postfix/smtpd[16044]: A12896A0654: client=localhost.localdomain[127.0.0.1]
    Feb 25 14:50:23 mail postfix/cleanup[16040]: A12896A0654: message-id=<[email protected]om>
    Feb 25 14:50:23 mail postfix/smtpd[16044]: disconnect from localhost.localdomain[127.0.0.1] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
    Feb 25 14:50:23 mail postfix/qmgr[15149]: A12896A0654: from=<[email protected]>, size=2976, nrcpt=1 (queue active)
    Feb 25 14:50:23 mail amavis[11226]: (11226-19) Passed CLEAN {RelayedOpenRelay}, [209.85.166.169]:53055 [209.85.166.169] <[email protected]> -> <[email protected]>, Queue-ID: 1FD786A03FD, Message-ID: <[email protected]om>, mail_id: hjzJk5GcXJZI, Hits: 0.052, size: 2515, queued_as: A12896A0654, dkim_sd=20161025:googlemail.com, 242 ms
    Feb 25 14:50:23 mail postfix/smtp[16041]: 1FD786A03FD: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.56, delays=0.3/0.01/0/0.24, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as A12896A0654)
    Feb 25 14:50:23 mail postfix/qmgr[15149]: 1FD786A03FD: removed
    Feb 25 14:50:23 mail postfix/smtp[16038]: A12896A0654: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0.03, delays=0.01/0/0.02/0, dsn=5.4.6, status=bounced (mail for mail.mydomain.de loops back to myself)
    Feb 25 14:50:23 mail postfix/cleanup[16040]: A877A6A06CE: message-id=<[email protected]>
    Feb 25 14:50:23 mail postfix/bounce[16039]: A12896A0654: sender non-delivery notification: A877A6A06CE
    Feb 25 14:50:23 mail postfix/qmgr[15149]: A877A6A06CE: from=<>, size=4991, nrcpt=1 (queue active)
    Feb 25 14:50:23 mail postfix/qmgr[15149]: A12896A0654: removed
    Feb 25 14:50:24 mail postfix/smtp[16038]: A877A6A06CE: to=<[email protected]>, relay=gmail-smtp-in.l.google.com[2a00:1450:400c:c07::1a]:25, delay=1.1, delays=0.01/0/0.13/0.95, dsn=2.0.0, status=sent (250 2.0.0 OK  1551102624 y2si7243573wrd.281 - gsmtp)
    Feb 25 14:50:24 mail postfix/qmgr[15149]: A877A6A06CE: removed
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is mail.mydomain.de listed in mydestination line in postfix main.cf file?
     
  3. ktownmods

    ktownmods Member HowtoForge Supporter

    nope


    Code:
    mydestination = localhost, localhost.localdomain
    
    i make the update to ispconfig 3.1.13p1 and after that this come, i recived emails before 2 hours on this mail

    and all other emails on this domain works only the [email protected]

    and what is this?

    comes on update
    Code:
    PHP Warning:  symlink(): File exists in /tmp/update_from_dev_stable.sh.Iheff6btHC/ispconfig3-stable-3.1-84cb11778c5e3971956e6dcdbdffde6d6c21c004/install/lib/installer_base.lib.php on line 2158
     
    Last edited: Feb 25, 2019
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Add the mail subdomain to mydestination line and restart postfix. The PHP warning is ok.
     
  5. ktownmods

    ktownmods Member HowtoForge Supporter

    mail.mydomain.de?
    this is also my host domain
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, and the host FQDN has to be in the mydestination line of postfix. If you miss to add it, then you'll get 'mail loops back to myself' error.
     
  7. ktownmods

    ktownmods Member HowtoForge Supporter


    Code:
    This is the mail system at host mail.example.de.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <[email protected]> (expanded from <[email protected]>): unknown user:
        "admin"
    
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you added 'example.com' as email domain in ispconfig and did you add a mail user in ispconfig with email address '[email protected]'?
     
  9. ktownmods

    ktownmods Member HowtoForge Supporter

    yes, other mails work e.g. [email protected]
    i had an maillist with this email and delete it can this cause this error?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, this might be related. Maybe there is something left. Try to search for it with:

    grep -R [email protected] /etc
     
  11. ktownmods

    ktownmods Member HowtoForge Supporter

    WTF!?


    Code:
    grep -R [email protected] /etc
    grep: /etc/systemd/system/timers.target.wants/snapd.snap-repair.timer: No such file or directory
    grep: /etc/systemd/system/multi-user.target.wants/snapd.core-fixup.service: No such file or directory
    grep: /etc/systemd/system/multi-user.target.wants/snapd.service: No such file or directory
    grep: /etc/systemd/system/multi-user.target.wants/snapd.seeded.service: No such file or directory
    grep: /etc/systemd/system/multi-user.target.wants/snapd.autoimport.service: No such file or directory
    grep: /etc/systemd/system/sockets.target.wants/apport-forward.socket: No such file or directory
    grep: /etc/systemd/system/sockets.target.wants/snapd.socket: No such file or directory
    grep: /etc/systemd/system/paths.target.wants/apport-autoreport.path: No such file or directory
    grep: /etc/systemd/system/cloud-final.service.wants/snapd.seeded.service: No such file or directory
    grep: /etc/systemd/system/final.target.wants/snapd.system-shutdown.service: No such file or directory
    grep: /etc/systemd/system/sysinit.target.wants/apparmor.service: No such file or directory
    
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    That's probably ok and not related. Seems as if the email address is not used in the config. Do you have a Linux user with the name 'admin' on the server?
     
  13. ktownmods

    ktownmods Member HowtoForge Supporter

    No
    i deleted [email protected] but nothing happend
    i create [email protected] and this works
     
  14. ktownmods

    ktownmods Member HowtoForge Supporter

    No Ideal?
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    No, not really. Please cjeck if the address is still in here:

    /var/lib/mailman/data/transport-mailman

    If that#s the case, remove it there and then run:

    /usr/sbin/postmap /var/lib/mailman/data/transport-mailman
     
  16. ktownmods

    ktownmods Member HowtoForge Supporter

    After deleting the [email protected] in /var/lib/mailman/data/transport-mailman i rund the command /usr/sbin/postmap /var/lib/mailman/data/transport-mailman
    But same message come Back to sender: unknown User Admin

    If i make a new emailadress always i have an email from ispconfig your Account is created, but not if i delete [email protected] and create it new
    And i also can send mail with it but not recieve
    Only on that email others work perfect
     
  17. ktownmods

    ktownmods Member HowtoForge Supporter

    @till
    in my mail.log is the warning:
    after running:
    it works now
     
    till likes this.

Share This Page