[SOLVED] PHPMyAdmin Login not work

Discussion in 'ISPConfig 3 Priority Support' started by ktownmods, Oct 16, 2018.

  1. ktownmods

    ktownmods Member

    Hey i followed the Perfect server ubuntu 18.04 tut with nginx and i can reach the phpmyadmin url
    but when i log in to my database it shows me 404 error

    Screenshot_153.png Screenshot_154.png
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to access phpmyadmin on port 8081.
     
  3. ktownmods

    ktownmods Member

    not work see screenshot

    without 8081 on roundcube it works
    eg mail.domain.tld/webmail

    Screenshot_157.png
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The screenshot explains that you are trying to access an HTTP website by https. use http://.. like you did in roundcube.
     
  5. ktownmods

    ktownmods Member

    ok with http:// it works but i like to use it with https://
    how do i do that?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you have to add ssl to the apps.vhost file. Use the SSL lines from ispconfig.vhost.
     
  7. ktownmods

    ktownmods Member

    in here?
    /usr/local/ispconfig/server/conf
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The apps vhost file and the ispconfig vhost file is in the /etc/nginx/sites-available/ folder.
     
  9. ktownmods

    ktownmods Member

    thanks it works
     
  10. ktownmods

    ktownmods Member

    now in phpmyadmin there is the msg with blowfish secret
    i changed the secret to 32 charakters on /var/lib/phpmyadmin/blowfish_secret.inc.php
    reboot but the msg goes not away
    also there a other msg see screenshot


    Screenshot_158.png Screenshot_159.png
     
    Last edited: Oct 17, 2018
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be that the value need to be set in a different file, depending on phpmyadmin version. Have you checked the files in /etc/phpmyadmin/ for this setting? And regarding the other problem, the phpmyadmin database seems to be missing or is incomplete. When you used debian or ubuntu, then you can try to reinstall phpmyadmin with:

    apt-get install --reinstall phpmyadmin

    and let the apt installer create the missing database and tables.
     
    jjsjjs likes this.
  12. ktownmods

    ktownmods Member

    I set the value in the different file but it doesnt work
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    If it does not work then the value is apparently still not set in the right file.
     
  14. ktownmods

    ktownmods Member

    I look Into it later thx
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    You can e.g. use grep to find other occurrences of that settings and it might be that the proposed reinstall of phpmyadmin fixes it too.
     
  16. ktownmods

    ktownmods Member

    Ok thanks
     
  17. ktownmods

    ktownmods Member

    this message only appears when i log in not as root user in phpmyadmin
    at root user it doesnt appear
    this with configurationstorage
    Screenshot_158.png
     
  18. ktownmods

    ktownmods Member

    i fix it with phpmyadmin fixer from github
     
    till likes this.

Share This Page