[solved] php-fpm add redis extension

Discussion in 'ISPConfig 3 Priority Support' started by Brett Wilton, Jun 17, 2018.

  1. Brett Wilton

    Brett Wilton Member

    I followed something like this https://www.howtoforge.com/tutorial/how-to-install-php-7-on-debian/ but did it for CentOS 7.5
    So I have installed php-5.6.31 and php-7.1.8 but was wondering the steps to add the redis extension to a specific php-fpm?
    I have the standard php install along with the two php-fpm's as above.
    I tried adding extension=redis.so to the end of the /opt/php-7.1.8/lib/php.ini file.
    /opt/php-7.1.8/bin/php --ri redis is showing "extension 'redis; not present which is correct.
    If that line is added I get :-
    Starting php-fpm [17-Jun-2018 17:07:32] NOTICE: PHP message: PHP Warning: PHP Startup: Unable to load dynamic library '/opt/php-7.1.8/lib/php/extensions/no-debug-non-zts-20160303/redis.so' - /opt/php-7.1.8/lib/php/extensions/no-debug-non-zts-20160303/redis.so: cannot open shared object file: No such file or directory in Unknown on line 0
  2. Brett Wilton

    Brett Wilton Member

    fiigure it out by using pecl, nice
    ahrasis and till like this.
  3. Brett Wilton

    Brett Wilton Member

    solved with :-
    cd /opt/php-7.1.8/etc
    pecl -C ./pear.conf update-channels
    pecl -C ./pear.conf install redis
    nano /opt/php-7.1.8/lib/php.ini and add line
    inside83 and till like this.

Share This Page