[Solved] PHP 7.x : Install ISPConfig 3 (Last version)

Discussion in 'Installation/Configuration' started by MasterBotWeb, Dec 16, 2015.


ISPConfig run with php 7.x

  1. Yes

  2. No

Results are only viewable after voting.
  1. MasterBotWeb

    MasterBotWeb New Member


    In php 7.x "mysql_connect" and other funtion "mysql_*" are removed.

    I have a sever with php 7.x (Last version), when I launch "php -q install.php", I have this error :
    "No PHP MySQL functions available. Please ensure that the PHP MySQL module is loaded." :(

    I try multiple php version (php 5.x and php 7.x) but mod_php is not supported with this.

    How to change all functions and request to mysqli or pdo for working with ISPConfig and php 7.x ? Thank you !! ;)

    Best regards,
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use PHP 7 in ISPConfig websites since the first PHp 7 alpha releases. See e.g.:


    The ISPConfig installer itself uses the System PHP of the Distribution and none of the supported Linux Distributions (Ubuntu, Debian, CentOS and OpenSuSE) uses PHP 7 yet as System PHP in its stable branches, so there is no need to support PHP 7 in the installer yet. When the first supported Linux distribution switches to PHP 7 in their stable branch, then the ISPConfig installer will support PHP 7 as well.
    MasterBotWeb likes this.
  3. MasterBotWeb

    MasterBotWeb New Member

    Thank you Till.
    php 7 is available for Debian Jessie on Dotdeb "main repository", if I update php 5.x to php 7.0.0. , Do I have a bug ?
    If it is a risk, I wait the last update of distribution to switch to php 7. ;) Thank you !

    Best regards,
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Dotdeb is not an official Debian repository. The System PHP of Debian 8 (Jessie) is 5.6.14, see https://packages.debian.org/jessie/php5 and thats why ISPConfig expects that on a Debian 8 System for the system (not the website) PHP version. Altering the supported setup by installing unsupported PHP versions will most likely break your server as that's untested and can lead to all kind of malfunctions.

Share This Page