[SOLVED] Only websites get backed up, not databases

Discussion in 'General' started by blackpit, Nov 22, 2016.

  1. blackpit

    blackpit New Member

    Hello, and thank you for this great panel you offer for free! We have been using it with all our clients now and it makes maintenance very easy. I have one problem however:

    A client's dedicated server has 10 websites running, and has configured daily backups for all of his sites. However, on 3 sites out of 10, only his website gets backed up but not the database. The other 7 sites get properly backed up, website and database. The 3 websites are running Wordpress. 1 of the 3 has been installed manually, 2 through APS installer. I have been trying to figure out what's different with these sites but can't get to a conclusion. What posts and settings on the server I have checked so far:


    The database is assigned to the correct website. Also, sudo and mysqldump are installed in the server. DB server is the same as WEB server, so using localhost in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf . Also, MySQL password is correct in that file (I can connect to mysql as root with this password), and it also does not contain any special characters, only A-Z, 0-9, and an underscore ( _ ) .

    Server is running Debian GNU/Linux 7.11 (wheezy) and ISPConfig version is

    The permissions on the /var/backup folder are as follows:
    hostname:~# ll /var/backup
    total 40
    drwxr-x--- 2 root root 4096 Nov 22 00:39 web1
    drwxr-x--- 2 web10 client10 4096 Nov 22 00:32 web10
    drwxr-x--- 2 root root 4096 Nov 22 00:39 web2
    drwxr-x--- 2 root root 4096 Nov 22 00:40 web3
    drwxr-x--- 2 root root 4096 Nov 22 00:40 web4
    drwxr-x--- 2 root root 4096 Nov 22 00:40 web5
    drwxr-x--- 2 root root 4096 Nov 22 00:40 web6
    drwxr-x--- 2 root root 4096 Nov 22 00:40 web7
    drwxr-x--- 2 root root 4096 Nov 22 00:42 web8
    drwxr-x--- 2 web9 client9 4096 Nov 22 00:32 web9

    The 3 websites with the issue are web2, web9, web10 .

    I can't seem to think of something else to try. Any ideas? Can I try/test something else?

    Best regards,
  2. blackpit

    blackpit New Member

    One of the 3 websites, web2, which is the one manually installed Wordpress, had a table in its database marked as crashed and tables could not be locked, so the database was not backed up. The last relevant entry with the error in the ISPConfig cron.log file was:

    Tue Nov 22 00:39:57 UTC 2016 mysqldump: Got error: 144: Table './c1xxxxxxxxxxxx/wp_statistics_useronline' is marked as crashed and last (automatic?) repair failed when using LOCK TABLES

    After running:
    check table wp_statistics_useronline;​
    in the mysql shell, and confirming the table errors, I ran:
    repair table wp_statistics_useronline;​
    and after rechecking the table, and everything was indeed fixed, I got a database backup along with this website on Wed Nov 23 00:40 UTC 2016. So I believe the issue with the 1 of the 3 websites was solved.

    The other 2 websites (installed through APS) didn't have any corrupt tables, but still weren't backed up, so I am still waiting for ideas on what to check next.

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    check the databases of these sites in ispconfig and ensure that a website is selected in the database settings.
  4. blackpit

    blackpit New Member

    Double checked, both databases are assigned to their website each.
  5. blackpit

    blackpit New Member

    UPDATE 2016-11-29
    The issue with the two website databases that were not being backed up was solved.

    Client's server had 99% usage on root filesystem, with 2.6GB free, and this seems was causing ISPConfig trouble. The two websites were the last ones created, and if ISPC backups work in an alphabetical web* order, then those backups failed silently. Anyway, client cleared up his server from older backups, and both databases were backed up on 2016-11-29 as they should. I will mark this as solved, I believe there's no need to investigate further.

    till likes this.

Share This Page