[SOLVED] no website directory or syslink created

Discussion in 'ISPConfig 3 Priority Support' started by Tomislav Aurednik, Sep 28, 2016.

  1. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    I have a really big problem. When I tried to create a new website with a client it just says that and it does not do anything for more than an hour.

    The following changes are not yet populated to all servers:
    • Delete website: 1
    • Create new website: 1
    • Update website settings: 1
    Storing updates can take up to one minute. Please be patient.

    I tried to make a website as admin and nothing. It shows it in ispconfig under website panel but it does not create a dir or syslink. I don't find any error logs that would tell me the problem.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    OK now i'm getting an error: - DEBUG - There is already an instance of server.php running. Exiting.
    I found that this could be a so called stale lock error and that i should run the command:
    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock

    I've got it from this page https://ma.juii.net/blog/fix-ispconfig-job-queue so I don't know if it's legit because I don't like deleting files that I don't know?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok to delete the lock file when the php process has died.
     
    Tomislav Aurednik likes this.
  5. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    Thanks! After deleting it and running /usr/local/ispconfig/server/server.sh everything was created.
     
  6. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    There is still a problem! Everytime that I create a website I get the error - DEBUG - There is already an instance of server.php running. Exiting. and I have to delete the lock file manually?! I'm running ISPConfig 3.0.5.4p9 on Ubuntu 14.04 LTS server.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that the php process on your server is unstable and does not finish. Use the debug mode from the link above to see why it dies after you deleted the lock file.
     
  8. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    I've found something wierd in /var/log/syslog

    Sep 28 13:47:20 web pure-ftpd: ([email protected]) [INFO] Logout.
    Sep 22 14:30:02 web CRON[25612]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    Sep 28 13:48:20 web pure-ftpd:

    ISPConfig monitors System-Log
    2016-09-28 13:31 web.8000plus.si Debug There is already an instance of server.php running. Exiting.
    2016-09-28 13:30 web.8000plus.si Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    2016-09-28 13:29 web.8000plus.si Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    2016-09-28 13:29 web.8000plus.si Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run server.sh on the shell after you deleted the lock file as described in the debug instructions to get the output.
     
  10. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    I'm doing by the instructions.
    This time I got the output:
    [email protected]:/var/log# rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock
    [email protected]:/var/log# /usr/local/ispconfig/server/server.sh
    28.09.2016-14:12 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    28.09.2016-14:12 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
     
  11. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    ok... after i did the instructions again i got:
    [email protected]:/home/administrator# /usr/local/ispconfig/server/server.sh
    28.09.2016-14:41 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    28.09.2016-14:41 - DEBUG - Found 3 changes, starting update process.
    28.09.2016-14:41 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    28.09.2016-14:41 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    28.09.2016-14:41 - DEBUG - Creating fastcgi starter script: /var/www/php-fcgi-scripts/web33/.php-fcgi-starter
    28.09.2016-14:41 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/xxxxxxxx.si.vhost
    28.09.2016-14:41 - DEBUG - Apache status is: running
    28.09.2016-14:41 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    28.09.2016-14:41 - DEBUG - Restarting httpd: service apache2 restart
    28.09.2016-14:41 - DEBUG - Apache restart return value is: 0
    28.09.2016-14:41 - DEBUG - Apache online status after restart is: running
    28.09.2016-14:41 - DEBUG - Processed datalog_id 1378
    28.09.2016-14:41 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    28.09.2016-14:41 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    28.09.2016-14:41 - DEBUG - Creating fastcgi starter script: /var/www/php-fcgi-scripts/web34/.php-fcgi-starter
    28.09.2016-14:41 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/xxxxxx.com.vhost
    28.09.2016-14:41 - DEBUG - Apache status is: running
    28.09.2016-14:41 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    28.09.2016-14:41 - DEBUG - Restarting httpd: service apache2 restart
    28.09.2016-14:41 - DEBUG - Apache restart return value is: 0
    28.09.2016-14:41 - DEBUG - Apache online status after restart is: running
    28.09.2016-14:41 - DEBUG - Processed datalog_id 1379
    28.09.2016-14:41 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    28.09.2016-14:41 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    28.09.2016-14:41 - DEBUG - Creating fastcgi starter script: /var/www/php-fcgi-scripts/web32/.php-fcgi-starter
    28.09.2016-14:41 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/xxxxxx.si.vhost
    28.09.2016-14:41 - DEBUG - Apache status is: running
    28.09.2016-14:41 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    28.09.2016-14:42 - DEBUG - Restarting httpd: service apache2 restart
    28.09.2016-14:42 - DEBUG - Apache restart return value is: 0
    28.09.2016-14:42 - DEBUG - Apache online status after restart is: running
    28.09.2016-14:42 - DEBUG - Processed datalog_id 1380
    28.09.2016-14:42 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats both ok, the first output meant that there were no pending updates and the second one was a run while there were pending updates. Both finished with the message "finished" which means that the run was successful and the lock file was removed. It's not easy to say what caused the script to fail before during cron run as it works correctly now.
     
  13. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    yeah but everytime I make a new website it locks and i have to manually remove the lock. What about that in syslog i get wrong date and time when the cronjob starts? I posted the output a few posts above.
     
  14. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    The problem was that my NAS crashed and there were cronjobs that tried to create backups on it. The NAS couldnt be remountet nor the proccesses killed that were trying to remount it. So after a restart everything is working again.
     
    till likes this.

Share This Page