Solved - limiting ftp to specific directory

Discussion in 'Installation/Configuration' started by Thilak, Sep 25, 2018.

Tags:
  1. Thilak

    Thilak Member

    I want to create a directory in the web root of my client. I would like to give access to the client only for that directory using a separate FTP account. The main reason behind this is, I am developing the website for him and I want to restrict him to the coding part of website. He will have a directory named contents and there he will upload his files. Those files will be read by my php files kept outside of that directory.
    This is like limiting the file uploads to specific directory for a FTP user.
    I am using ISPConfig 3.1 on Ubuntu 18.04
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Under Sites > FTP-accounts > {your ftp account > Options there is a "Directory" path, try setting that (I haven't tried, but it might be just what you need).
     
  3. Thilak

    Thilak Member

    Oh, I havn't seen the options TAB. Thats what I wanted:)
    Thank you.
     
  4. Thilak

    Thilak Member

    Actually there is a problem. I have created a directory called contents and created a new FTP user with default directory to that folder. But, newly created user doesn't have permission to that folder. How can I solve it? That folder was created by root user.
     
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Don't create directories or files as root to user directories.
    Now root has to change owner and group of contents/. Use chown from command line.
     
  6. Thilak

    Thilak Member

    Worked. I have remove that directory and let ISPC create that directory. Now it is working fine.
     
  7. Thilak

    Thilak Member

    Isnt there any option to accept the answer in this forum? Will it be closed automatically or should I select any answer as accepted?
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    No accept. But there is a thumbs-up Like-button. You can use thread tools to edit title, add solved to the beginning of title.
     

Share This Page