[SOLVED] letsencrypt.log not updating

Discussion in 'ISPConfig 3 Priority Support' started by Turbanator, Feb 4, 2017.

  1. Turbanator

    Turbanator Member HowtoForge Supporter

    So before I go into "letsencrypt isn't creating ssl"...first I need to figure out why the log file isn't updating since the day I installed letsencrypt.

    Background: this was a Perfect Wheezy server which I upgraded to Jessie, then followed the Perfect Jessie install to get letsencrypt.
    So far I can't get it to work (it works fine on my other Jessie server), but the log file isn't even updating in order for me to diagnose.

    Any thoughts, or any other log file I can look at which will point to something?
    note the file date vs today being Feb 3?

    drwx------  2 root root 4096 Feb  3 14:47 .
    drwxr-xr-x 20 root root 4096 Feb  3 15:21 ..
    -rw-r--r--  1 root root 2085 Jan 12 10:45 letsencrypt.log
    -rw-r--r--  1 root root    0 Jan 12 10:44 letsencrypt.log.1
  2. Turbanator

    Turbanator Member HowtoForge Supporter

    I moved ispconfig to debug mode and checked the cron.log but it didn't give anything useful that I could tell. Also, to eliminate a permission issue, I changed letsencrypt.log to 777 and it still didn't update and there wasn't an "unable to write" error anywhere. Further, I manually ran /opt/certbot/certbot-auto. It updated version to 0.11.1 and it did write a new /var/log/letsencrypt.log...BUT when I tell ISPC 3.1.2 to enable the ssl, nothing happens and the monitor status is only "working" for a few seconds, whereas on my other server where letsencrypt works, the monitor status is there for much longer as it successfully creates ssl.
  3. Turbanator

    Turbanator Member HowtoForge Supporter

    FIXED: I ran the debug mode again and found this in the cron.log
    UnicodeDecodeError: 'utf8' codec can't decode byte 0xb6 in position 147: invalid start byte in /usr/lib/pymodules/python2.7/rpl-1.5.5.egg-info

    Seems there is is an unreadable char in the authors name, so I removed it in that file and all is good!
    till likes this.

Share This Page