[solved] Lets Encrypt with multiple domains on one IP

Discussion in 'ISPConfig 3 Priority Support' started by daniel712, Mar 16, 2021.

Tags:
  1. daniel712

    daniel712 New Member HowtoForge Supporter

    Hi Friends,
    I am hosting multiple domains on a single server with 1 IPv4 Address. The Lets Encrypt SSL Certs are restricted for only 1 IP Address. Is there an elegant solution to have multiple SSL Sites running over the one IPv4 Address?

    For now i assigned seperate IPv6 addresses for the domains and have them all running SSL at least over IPv6.

    Thanks for advice
    Daniel
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    That sounds like misunderstanding of how things work; are you having a particular problem? You might see the lets encrypt faq post and the read before posting post, they cover some common issues and how to troubleshoot.
     
    Last edited: Mar 16, 2021
  3. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    No. For multiple domains per one public ip each may obtain their own LE SSL certs with no problem. Head to LE SSL FAQ to resolve any problems you might have as suggested above by @Jesse Norell.
     
  4. daniel712

    daniel712 New Member HowtoForge Supporter

    OK, thanks. That was a misunderstanding because in the manual under 5.4 it says "please note that you can have only one SSL web site per IP address" ... that was a bit misleading.

    The Sites work now. I have still a SSL problem with one site: I disabled the SSL/Lets Encrypt Box and reenabled it again after some time. But when i try to open the Site Firfox complains: "This Cert, is only valid for the following name ..." The name is another Site of my hosting.
    May i force a renew of that cert manually? Or how to fix it?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page