[SOLVED] ISPConfig3 not creating .sieve files

Discussion in 'Installation/Configuration' started by linuxisfun, Nov 28, 2017.

  1. linuxisfun

    linuxisfun New Member

    I'm using ISPConfig3 on a Debian 8 server. I'm using Dovecot for mail delivery. My httpd is Apache2. I can create a .sieve file in the Maildir directory of the user, manually enter sieve rules, and they will be obeyed. When I attempt to create them with ISPConfig3, however, the sieve rules are not created and the file is not created.
    The file should be located at /var/vmail/%d/%n/.sieve, and manually creating this file and populating it with sieve rules has the result of Dovecot respecting those sieve rules on delivery of new mail.
    The mail_user table in the dbispconfig MySQL database has the /var/vmail/%d/%n directory set as maildir, and /var/vmail set as the homedir.
    I have ensured that the ispconfig user has write access to the /var/vmail/%d/%n directories, and I have tried manually editing the /usr/local/ispconfig/server/plugins-enabled/maildeliver_plugin.inc.php file to force ISPConfig3 to set the sieve_file variable as /tmp/file.sieve, but that file also does not get created by ISPConfig3 when I save custom mail rules.
    I have ensured that all mail-related plugins are enabled:
    /usr/local/ispconfig/server/plugins-enabled# ln -s /usr/local/ispconfig/server/plugins-available/maildeliver_plugin.inc.php maildeliver_plugin.inc.php
    /usr/local/ispconfig/server/plugins-enabled# ln -s /usr/local/ispconfig/server/plugins-available/mailman_plugin.inc.php mailman_plugin.inc.php
    /usr/local/ispconfig/server/plugins-enabled# ln -s /usr/local/ispconfig/server/plugins-available/mail_plugin.inc.php mail_plugin.inc.php
    /usr/local/ispconfig/server/plugins-enabled# ln -s /usr/local/ispconfig/server/plugins-available/maildrop_plugin.inc.php maildrop_plugin.inc.php
    /usr/local/ispconfig/server/plugins-enabled# ln -s /usr/local/ispconfig/server/plugins-available/getmail_plugin.inc.php getmail_plugin.inc.php

    I do see the lines for the changes that I am making in the web frontend of ISPConfig3 in the sys_datalog table of the dbispconfig database, but I do not see them show up in any of the log files in /var/log/ispconfig, even after setting logging to verbose.
     
  2. linuxisfun

    linuxisfun New Member

    I was using an old version of ISPC that was not putting information into log files. I updated it, which caused errors to show up in logfiles. If errors happen, the script will not finish, and the sieve files will not be created. Resolved errors in log and the sieve files were created.

    :)
     

Share This Page