[SOLVED] ISPConfig redirecting everything to main site? Help!

Discussion in 'Installation/Configuration' started by edooze, Nov 26, 2015.

  1. edooze

    edooze Member

    Hi Guys,

    While trying to work through adding an SSL cert to the control panel (in my previous post), I downloaded and ran the script to change the CSR. I selected no for everything except to create a backup of my configuration, it's never a bad idea.

    Now, all sites are being redirected to the main domain. My clients websites are all down.

    I also notice that the script I was told to run changed the branding back to ISPConfig from my own, so it obviously changed some things.

    Can someone provide help here, please? All sites are currently unreachable, except for the main site obviously. Aah!
    The control panel is accessible via port 8080.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ensure that you dont mix * and Ip address in website settings, use either * or the IP for all sites.
  3. edooze

    edooze Member

    Thanks, Till. I have restored a snapshot from earlier in the day, it was something of a dealbreaker, and so have to make a few more changes to bring everything back up to speed (was doing a lot of work overnight).
    I'll try and apply the cert again, but am a bit concerned that I might break it. Have you got any suggestions here?
  4. edooze

    edooze Member

    Okay, so it happened again! This time I tried what you suggested and it worked. Not sure why it changed, but glad I was able to recover. I think I'm slowly getting the hang of ISPConfig's little tricks.

    Thanks again.

Share This Page