[SOLVED] ispconfig, Jobqueue counting, no changes, no log updates etc.

Discussion in 'Installation/Configuration' started by TerenceHill, Feb 6, 2020.

  1. TerenceHill

    TerenceHill New Member

    SOLVED

    since 4 weeks ISPConfig (3.1.15p2), dont work anymore and i dident change anything.
    The Jobqueue is counting and counting higher (45) but it is not processed (well).
    - cant create new SSL Certs
    - change from no PHP to PHP issent working (clients show 403 forbiden)
    - delete clients Website, removes frome the Website list, but dont delte the directory on Server
    and so on

    Every LogFile in ispconfig is from Sun Dec 29 11:xx h

    Server: server.name.de (Debian Stretch) ISPConfig 3.1.15p2
    State: info (0 unknown, 0 info, 1 warning, 0 critical, 0 error)
    -- Warning
    -- One or more components needs an update [More...]

    But the System is up to date

    Debian Jessie with php 7.3 / 7.4 and default.
    Code:
    [email protected]:/home/terencehill# php
    php         php7.0      php7.3      php7.4      php-cgi     php-cgi7.0  php-cgi7.3  phpdismod   phpenmod    php-fpm7.0  php-fpm7.3  phpquery
    Code:
    The following changes are not yet populated to all servers:
    Delete FTP user: 1
    Create FTP user: 2
    Update FTP user: 11
    Update email user: 1
    datalog_status_u_server: 12
    datalog_status_u_server_ip: 1
    Delete database: 1
    Create new database: 1
    Update database: 1
    Update database user: 1
    Delete website: 1
    Update website settings: 12
    
     
    Last edited: Feb 6, 2020
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. TerenceHill

    TerenceHill New Member

    Thanks for the link.

    Your sollution from this Thread, is working:
    https://www.howtoforge.com/communit...ned-function-mb_detect_encoding-in-tmp.78240/


    Debug Error:
    Code:
    06.02.2020-17:38 - WARNING - There is already a lockfile set, but no process running with this pid (17912). Continuing.
    
    
    06.02.2020-17:38 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    PHP Fatal error:  Uncaught Error: Call to undefined function mb_detect_encoding() in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php:523
    Stack trace:
    #0 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(183): db->escape()
    #1 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(301): db->_build_query_string()
    #2 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(340): db->_query()
    #3 /usr/local/ispconfig/server/lib/app.inc.php(189): db->query()
    #4 /usr/local/ispconfig/server/lib/classes/plugins.inc.php(155): app->log()
    #5 /usr/local/ispconfig/server/server.php(174): plugins->raiseAction()
    #6 {main}
      thrown in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 523
    
     
    Last edited: Feb 6, 2020
  4. Jesse Norell

    Jesse Norell Well-Known Member

    you need to install php#.#-mbstring for your system php version .. which I thought was 5.6 on jessie, but maybe it's 7.0
     
    TerenceHill likes this.
  5. TerenceHill

    TerenceHill New Member

    Thanks but got it allrdy :)
     
    Jesse Norell likes this.
  6. Jesse Norell

    Jesse Norell Well-Known Member

    Sorry, I missed the 'solution .. is working' bit. :)
     
    TerenceHill likes this.

Share This Page