[SOLVED] Install Jailkit failed

Discussion in 'General' started by Jean-François Questiaux, Jun 21, 2018.

Tags:
  1. Hi, I'm trying to install Jailkit on a new Debian 9 server and I get stuck with this error:

    debian/rules:74: recipe for target 'install-arch' failed
    make: *** [install-arch] Error 25

    It seems it 's a known issue but the few docs I found about this are utterly incomprehensible to me.
    Does anyone have a clear advice or solution to this problem? I'm really stuck now as I know I can't install ISPconfig before jailkit.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    How are you installing jailkit? Howto chapter 17 is the way I have used. I have had no problems with installing jailkit on Debian 8 or 9 if I have installed the build-essential et al packages the howto tells me to install.
     
  3. Yes, I installed it also on other servers (debian 8 and 9) and it worked.
    I did install the requested packages prior, but this time something is missing.
     
  4. The only thing that is different from the previous installs is that on this server the /var directory is located on a second disk.
    So I have:
    /dev/xvda : main system (all usual directories, except /var)
    /dev/xvdb : /var directory

    I guess that can be the issue, but I have no clue on what to do.
     
  5. Jesse Norell

    Jesse Norell Well-Known Member

    I've not run into that before, but if you've built jailkit on other debian9 systems, just copy the .deb files from one of those and they should install and work fine (assuming similar machine architecture).
     
  6. ahrasis

    ahrasis Well-Known Member

    There is a minor fix added to perfect server 18.04 tutorial but I am not sure that is relevant to your case.
     
  7. Well I think it is : in the ISPConfig 3.1 manual, this line is missing:
    echo 5 > debian/compat
    and apparently it makes all the difference as I could install Jailkit successfully.
     
    ahrasis likes this.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    If this line is missing or not depends on the used Linux Distribution version. The manual is for Debian 8. If you look at the instructions for Debian 9 (Debian 9 perfect server guide), then you'll see that the compat level is set there.
     
    Kátia and ahrasis like this.

Share This Page