[SOLVED - IGNORE] Additional PHP versions

Discussion in 'Installation/Configuration' started by GeorgeG, Jan 23, 2018.

  1. GeorgeG

    GeorgeG New Member

    Once the machine was restarted everything worked... somehow...

    Hi All,
    I have a multi-server installation:
    2 Web Servers (Apache2) - 1 of them is acting as the ISPConfig master server
    1 DNS
    1 DB
    1 Mail
    All running Ubuntu 14.04LTS with all the latest updates and ISPConfig 3.1.11.
    I have successfully installed 2 additional PHP versions (I only need 5.6 and 7.0) on both Master and Slave Web server.
    I then created the entries in System > Additional PHP Version. 2 for the master instance, and 2 for the slave instance.

    The additional PHP versions are visible when editing a website properties.
    On the Master server, everything is working fine.
    On the Slave server, regardless of which version is selected, the default version (5.5) is actually used.
    Additional information:
    - All websites are setup to work with PHP_FPM - On Demand.
    - I have crawled the logs for leads/clues... but have found nothing
    - On slave, I can see php5-fpm, php5.6-fpm and php7.0-fpm with (output of "ps aux |grep php") but only php5-fpm spawns processes.
    - The websites on the slave webserver are functional (well phpinfo() is).
    - On both boxes I have installed the additional PHP versions via the ppa:eek:ndrej/php repository (I have another standalone UBUNTU 14.04 box that works fine with multiple PHP versions from that repo).

    Can anyone offer a suggestion of where to look for clues?

    Last edited: Jan 23, 2018

Share This Page