[SOLVED]How to access EXAMPLE-dotCOM in ispconfig 3 on SERVER1.EXAMPLE-dotCOM

Discussion in 'Installation/Configuration' started by LAKSHA, Dec 18, 2015.

?

In which debian release ispconfig 3 is a better install?

Poll closed Jan 1, 2016.
  1. Squeeze - Debian 6

    0 vote(s)
    0.0%
  2. Wheezy - Debian 7

    0 vote(s)
    0.0%
  3. Jessie - Debian 8

    100.0%
  1. LAKSHA

    LAKSHA Member HowtoForge Supporter

    [​IMG]

    Suppose we use server1.example.com for installing all the servers and ispconfig 3
    now once inside the admin panel how do we add example.com ?
    Please correct me if i am wrong
    i am given a VPS Control Panel and i am given 2 sets of nameserver total 4 nameservers
    ns1,ns2,ns3,ns4 and their ip addresses
    before installation i followed these steps in order
    I logged into my domain registrar
    I changed nameservers and pointed to their given ip address
    i created A record example.com pointing to the ip address given for the VPS
    i created A record with server1.example.com pointing to the same ip address as example.com
    so now i have 2 A records pointing to the same ip address and i have my nameservers configured correctly
    i logged in to vps control panel
    changed the hostname to server1.example.com
    i added the domain name example.com to the VPS Control panel
    In DNS Section
    i created A record example.com pointing to the ip address given for the VPS
    i created A record with server1.example.com pointing to the same ip address as example.com
    I am on debian 6 and so i used https://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-dovecot-ispconfig-3-p4
    after the first installation i executed these steps in order
    I logged in to ispconfig 3
    i changed the password
    i raised the default firewall
    i made 2GB/20GB Unlimited and 3GB/30GB unlimited Main Templates in client section
    I created Client 1
    Now i added the example.com as Website 1 for Client 1
    Now i created zonefile with Client 1 Ownership and with correct details as follow
    Server server1.example.com
    Client Client 1 (Client-One, C1)
    Zone (SOA) example.com
    NS ns1.nameserver.com.
    Email example-email.gmail.com.
    Refresh 7200 Seconds
    Retry 540 Seconds
    Expire 604800 Seconds
    Minimum 86400 Seconds
    TTL 3600 Seconds
    Allow zone transfers to these IPs 1.2.3.4 (Correct IP Provided by Hosting Company which belongs to my VPS)
    Also Notify 1.2.3.4 (Correct IP Provided by Hosting Company which belongs to my VPS)
    Update ACL left blank
    Active chechbox checked
    Now i created ftp user for Client 1 and Website 1 which is example.com with default values
    Now the PROBLEM is
    when i log in to ftp of client 1 which is example.com and view the index file it givers me following contents
    HTML:
    <body>
    <div id="page">
    <div id="header" class="header">
    <h1>Welcome to <!--ADRESSE//-->your website!<!--ADRESSE//--></h1>
    </div>
    <div id="content">
    <h2>This is the default index page of your website.</h2>
    <p>This file may be deleted or overwritten without any difficulty. This is produced by the file <b>index.html</b> in the <b>web</b> directory.</p>
    <p>For questions or problems please contact <!--SUPPORT//-->support<!--SUPPORT//-->.</p>
    </div>
    <div id="footer">
    <p>Powered by <a href="http://www.ispconfig.org">ISPConfig</a></p>
    </div>
    </div>
    </body>
    while if i go on the browser and type http://example.com i get the following contents
    HTML:
    <html><body><h1>It works!</h1>
    <p>This is the default web page for this server.</p>
    <p>The web server software is running but no content has been added, yet.</p>
    </body></html>

    [​IMG]

    my hostname command is showing server1.example.com
    So the problem is that on http://server1.example.com and http://example.com the same file is shown and the file which is in webfolder of my Website 1 for Client 1 is not shown .
    Also FTP is a problem.I can just login to the client folder and not any other folder.
    How to correct any mistakes?
    were my steps wrong anywhere?
    If you like this conversation and if you like my cute images, just imagine how i could contribute to your projects :)
    Please do connect with me to put awesomeness into project what you are doing! :cool:
    [​IMG]
    Hashtags #Newbie #FirstWeekOnLinux #UnbornChildOfDebian #HelpNeeded #ISPConfig3 #MyFirstISPConfig3Installation #MyFirstEverLinuxInstallation #SadToBeYourBurden #Sad #WillingToHelpInMyDomain #Wordpress #SocialMedia #BusinessCollaborations #HappyToConnect #LookingForBusinessPArtners #BusinessAssociatesNeeded #LoveNThanks #BlessedBe
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You will always install on a current version of an OS, and that's Debian 8.

    Apache will not show the right website when either IP address or domain name does not match. That's why I asked you if the server is behind a router, on servers behind a router you have to select the internal IP for apache and not the external IP, as alternative you can also try to use * instead of the IP address in the website settings.

    Thats no problem at all as its the desired behaviour. A FTP account of a website can access this website only and not the whole server. If an ftp account would be able to access the whole server then your clients would be able to manipulate the websites of other clients or take over the control of your server.
     
    LAKSHA likes this.
  3. LAKSHA

    LAKSHA Member HowtoForge Supporter

    My hosting provider is not replying if my vps is behind router. :-(
    I will update you asap
    @till thank you for your revert!
    I will be updating you on the progress :)
     
  4. LAKSHA

    LAKSHA Member HowtoForge Supporter

    I have reinstalled with https://www.howtoforge.com/tutorial/ispconfig-install-script-debian/
    I had the following issues
    it never asked me to choose between roundcube and squirrelmail
    now at the end i am having problem with setting up the remote user because only roundcube path is given .
    Please guide me on how to setup for squirrelmail
    ;) Thank you
     
  5. LAKSHA

    LAKSHA Member HowtoForge Supporter

    [email protected] :/# find -name config.inc.php
    ./tmp/ispconfig3_install/interface/lib/config.inc.php
    ./etc/phpmyadmin/config.inc.php
    ./usr/local/ispconfig/interface/lib/config.inc.php
    ./usr/local/ispconfig/server/lib/config.inc.php
    ./usr/share/phpmyadmin/setup/frames/config.inc.php
    ./var/lib/phpmyadmin/config.inc.php
    since no roundcube was installed instead squirrelmail was installed so i guess there is no such file created.
    I check the /var/lib/squirrelmail dir and it does not contain anything like that file
     
  6. LAKSHA

    LAKSHA Member HowtoForge Supporter

    My Error Log as follows
    [email protected]:/# cat /var/log/ispconfig_setup.log
    Synchronizing state for spamassassin.service with sysvinit using update-rc.d...
    Executing /usr/sbin/update-rc.d spamassassin defaults
    Executing /usr/sbin/update-rc.d spamassassin disable
    insserv: warning: current start runlevel(s) (empty) of script `spamassassin' overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `spamassassin' overrides LSB defaults (0 1 6).
    ERROR: Problem with internal logger (UpdateLogFile = /var/log/clamav/freshclam.log).
    sed: can't read /etc/inetd.conf: No such file or directory
    Generating a 2048 bit RSA private key
    ..............................................+++
    ...................................+++
    writing new private key to '/etc/ssl/private/pure-ftpd.pem'
    -----
     
  7. LAKSHA

    LAKSHA Member HowtoForge Supporter

    If i use 1.2.3.4. for server1.example.com
    and the same ip 1.2.3.4 for example.com
    it still takes me to the index file of server1.example.com even if i put example.com in the browser.
    So basically the index file of server1.example.com is been shown even on example.com
    and as usual the client 1 and the website 1 is ignored
    I have deleted the A record of example.com right now which was pointing to 1.2.3.4 and i have kept A record for server1.example.com pointing to 1.2.3.4
    now the index page wont show the same stuff
    Positive side is that i have few hours to install this. if not then i will have to pay and revert back to cpanel which will be a technological setback to us since we really really loved ispconfig3
    I am ready to share my login privately just let me know how.
    regards,
    L
     
  8. LAKSHA

    LAKSHA Member HowtoForge Supporter

    This is how we did it
    The entire problem mentioned above could be addressed by the doing following
    Log In to the IspConfig 3
    Setup your Templates in Clients -> Limit Templates
    Select Main Templates and give it a name and setup everything in limits tab
    Now create your client
    Now go to the Sites tab
    Create New Site with your example.com your own domain name on whose subdomain you have ispconfig 3 installed
    Associate it with you client account
    now on the left side panel find FTP account and create NEW account linking it to the client and website
    go to OPTIONS tab and copy the path of the FTP - Example : /var/www/clients/client1/web1
    Now go to website on the left and add new website
    fill all details and just let there be * in IP 4 field if you dont have a dedicated IP or if you are confused
    Now go to REDIRECT tab inside the Website
    and choose redirect type to L
    Paste the Path you copied from the Options tab of FTP user
    The path has to be covreed with forward slash at both ends
    so
    /var/www/clients/client1/web1
    will be after adding 'web' folder to it [Thanks to @till for pointing out my mistake]
    /var/www/clients/client1/web1/web/
    If you face a problem please do connect with @till or me @LAKSHA
    please note that i am a newbie and @till is accomplished in ISPC3 and Linux

    [​IMG]
    Hashtags #Newbie #FirstWeekOnLinux #UnbornChildOfDebian #HelpNeeded #ISPConfig3 #MyFirstISPConfig3Installation #MyFirstEverLinuxInstallation #SadToBeYourBurden #Sad #WillingToHelpInMyDomain #Wordpress #SocialMedia #BusinessCollaborations #HappyToConnect #LookingForBusinessPArtners #BusinessAssociatesNeeded #LoveNThanks #BlessedBe
     
    Last edited: Dec 18, 2015
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no roundcube package for Debian 8, that's why squirrelmail is installed automatically.

    Not sure why you added a redirect as that not required and opens up a real security hole. The website root directory is /var/www/clients/client1/web1/web and not /var/www/clients/client1/web1/, the FTP user can access /var/www/clients/client1/web1/ off course as it has to maintain also cgi scripts which are not in the website root.

    I installed a server for a client today by using the automated install script and setup a website for that client. The steps where:

    1) Start the automated instal scripts and accept the default values (enter your own hostname and password off course).
    2) Login to ispconfig and set a new admin password to ensure that no one can login with the default password "admin".
    3) Click on "new website" in ISPconfig, enter the domain name "domain.tld" (I'll not disclose the real domain name of that client off course) and press save. The domain "domain.tld" has to point to the server IP in DNS off course.

    After 60 seconds I was able to reach the newly created website in the browser.

    Then I added a FTP user by clicking n the "Add FTP User" button, selected the website, entered username and password.

    After 60 seconds I was able to login to the website directory by FTP.
     
    LAKSHA likes this.
  10. LAKSHA

    LAKSHA Member HowtoForge Supporter

    Great:) @till i did the exact same thing
    and i got the exact same problem again.
    dont know whats wring with my instances
    i have another vps with Debian 8 clean it is
    let me install it there also.
    hey can you overlook it by teamviewer so something?
    If not then let me know how i could share any details with you like the logs and everything
    Thank you for your super support @till
     
  11. LAKSHA

    LAKSHA Member HowtoForge Supporter

    Hey @till I corrected my mistake in the path
    Thank you dear
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe you just mix up that the FTP root directory is /var/www/clients/client1/web1/ while the website root is /var/www/clients/client1/web1/web/ as the FTP user shall be able to access cgi and private folder. so when you want to upload a html file into th web root, then you just go to the "web" dir in your FTP client by clicking on "web" before you upload the files.

    If you dont want to be able use dynamic cgi scripts and dont want to upload files into the safe "private" folder and instead be directly in the web folder by FTP login, then just alter the ftp user root directory on the options tab of the FTP user and append /web to it. But I wont do that on any of my servers as I use the extended functionality that requires access to cgi and private folders regularly.
     
    LAKSHA likes this.
  13. LAKSHA

    LAKSHA Member HowtoForge Supporter

    i have kept my path till /web1 in ftp and for redirect i am having /var/www/clients/client1/web1/web
    but as you said there is a security issue with that.i dont know what do i do now.
    If i dont keep that path redirect then the index file at server1.example.com and example.com is the same
    it does not go to the web folder and look for the index files.
    are conversations private @till ?
    Let me know so i could share cred / details
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    There should be no redirect added at all as the website root is already /var/www/clients/client1/web1/web, remove that redirect.

    Support by PM or remote Login is business support and not available for free.
     

Share This Page