Solved - FTP getting stuck in middle

Discussion in 'Installation/Configuration' started by Thilak, Sep 27, 2018.

  1. Thilak

    Thilak Member

    I am using ISPConfig 3.1on ubuntu 18.04. I have created some FTP accounts.
    When I try to upload some files using filezilla, the FTP is getting stuck. The connection is TLS encrypted and there is no problem with my internet connection.
    I was using CWP previously on CentOS7 and that too had PureFTP by default. Due to that problem I shifted to ISPC and now I am facing similar issues with ISPC also.
    In CWP, I was facing slow directory listing error, file transfer getting stuck etc. If I use SSH file transfer, it works fine. In ISPC, now I am having issue with file upload (Getting stuck in middle of transfer). Previously it was working. Suddenly problem occured.
    What could be the issue?
  2. Thilak

    Thilak Member

    Solved for time being after rebooting my server
  3. Thilak

    Thilak Member

    It seems to be not solved. Not repeated afterwards in ISPC. Hope it will not occur again.
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Make sure you have a passive port range set, allowed in your firewall(s) and any NAT. Does this happen to any other ftp client? Does it happen with an ftp client on your local network too, or only internet connections? Can you still ping the server when that happens? Check if logs on either end have any clues.

    Beyond that, I'd be surprised if the problem was on the server end, but start looking at packet traces from various points in your network path and see where things stop working.

Share This Page