[SOLVED]Error in executing php-fpm on buildt php-5.6 on debian 9

Discussion in 'ISPConfig 3 Priority Support' started by StefanoBertoli, May 18, 2018.

  1. StefanoBertoli

    StefanoBertoli Member HowtoForge Supporter

    I try to remove the php-fpm5.6 with apt-get. I installed yesterday before recopile with gd
    If something will be remved i reconfigure the compiled version
     
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    it doesn't matter if they look different or have different names. www is just a default to be used by system configured stuff.
    But at least one pool like www is needed or else the daemon won't start.
     
  3. StefanoBertoli

    StefanoBertoli Member HowtoForge Supporter

    I uninstalled php5.6 official package and check all it's ok
    so now which didn't show any php but only php7.0 default on debian9

    I changed configuration file as suggested and wrote before.
    All is up and running.

    I mark solved and if is possible let's upgrade the howtoforge guide
     
    till likes this.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I'll take a look at the howto and update it.
     
    ztk.me likes this.
  5. Honza

    Honza Member

    Sorry to bump this old thread but I'm having exactly same issue and this wasn't quite clear to me what do I need to actually do.

    So when I do: # /opt/php-5.6/sbin/php-fpm
    I get:
    So it's pretty much same thing.
    If I do: /opt/php-5.6/etc# ls
    Output is:
    so clearly directory /php-fpm.d is missing.

    How do I go about that? What configuration files are missing and where do I need to create them?

    Thanks a lot in advance.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Try this:

    mkdir -p /opt/php-5.6/etc/php-fpm.d
     

Share This Page