[solved] Error "1." with no message when trying to add database

Discussion in 'Installation/Configuration' started by Hbod, Aug 10, 2020.

  1. Hbod

    Hbod Member

    Hi,

    my customer reached out to me, because he wasn't able to create a database. I checked his limits and he has 3 of 5 databases. I logged in as the customer from the panel and I could reproduce it.

    Also watched developer ajax responses and its just and empty alert div with "1." as content.
    I double checked that the selected services and server are fine.

    I tried to create the database as admin and that worked perfectly fine. My customer was also able to create the user, its just the database thats not working for him.

    Debian 10, I'm on 3.1.15p3
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    Check web server and php daemon error logs, and also look for ISPConfig's internal IDS tripping (check /var/log/ispconfig/ispconfig.log and Monitor > System-Log).

    Is this a single server or multi-server install? If multi-server, did you assign the database server in this client's limit template (or custom limits)?

    If that doesn't find anything, what is the full request in the developer console (obfuscate session id, but what is the url and parameters?).
     
  3. Hbod

    Hbod Member

    Hi Jesse,

    checked /var/log/ispconfig/ispconfig.log and Monitor > System-Log and they are empty. There is some IDS log but from July, nothing new. The last entry was for using a blacklisted vhost folder "dev" but that was also not related to that client.

    I had to assign web-server and mysql server in order to make it work.
    Maybe the error message should be adjusted. A single "1." wasn't helpful. @till
    If you don't want to expose a message here to the user, a better error code might be helpful for debugging

    Thanks for pointing to the right direction.

    How to reproduce:
    - Generate a client template and assign database but no webserver and vice versa
    - Try to generate a database as user

    It will generate a "1." error message.

    So my issue is solved. Thanks
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

Share This Page