[solved] dovecot error after restorage

Discussion in 'ISPConfig 3 Priority Support' started by niemand-glaumy, Mar 6, 2019.

  1. Sers.
    I zipped all my old /var/vmail/ folders and now am unzipping them into the folders after creating mail accounts in ISPC.

    I ran into some permissions trouble I solved via "chmod -R +rwx /var/vmail/", now I still have this error left in "systemctl status dovecot.service":
    Mar 06 01:33:53 web dovecot[2703]: imap([email protected]): Error: Can't create log file /var/vmail/domain.tld/name/Maildir/dovecot.index.log: Index is read-only
    Do I need to "chown" the folders? If yes: for what user:group?
    If no: What's the solution?

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    "chmod -R +rwx /var/vmail/",
    Bad idea. Don't do that.
    Check what owner, group owner and permissions are on a mailbox you created with ISPConfig and have not changed yet.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    All files and folders in /var/vmail must be owned by the vmail user and vmail group, so doing a:

    chown -R vmail:vmail /var/vmail

    is fine. But never do something like that on /var/www!

    The original problem is probably that you used zip to archive the files and not tar. zip can not store the correct file and folder ownerships. When moving var/vmail to another server, then use:

    tar pcfz email.tar.gz /var/vmail

    to craete the archive.
    niemand-glaumy likes this.
  4. Thanks Till, that explains a lot and I will try to remember to use tar in the future.
    For my webspace: I decided to create the pages and FTP users and upload things that way. That should avoid permission issues.

Share This Page