(SOLVED) Domain URL and Email not working

Discussion in 'Installation/Configuration' started by kettgun, Apr 29, 2020.

  1. kettgun

    kettgun New Member

    I have problems with dependencies when installing ISPConfig in my VPS. It took few hours to follow steps in installing it, and at the end always failed. So I tried to install automated ISP Config, and I found error related to pure-FTD. After fixing it (install update-inetd), I then “sucecssfully” installed ISP Config 3.

    I can access ISPConfig through my public IP, but failed accessing it through domain name. In mypublicIP:8080 I have followed the tutorial in configuring DNS for my working domain both from the forum and youtube. I use hostname: srv.mydomain.net; domain and dns: mydomain.net; nameserver (NS): ns1.mydomain.net and ns2.mydomain.net. But in who.is my DNS not found. If I apply such setting to other web panel (I don’t want to mention) the DNS records exist/normal in who.is and mydomain.net:8080 can be accessed. This means that my domain is active and my DNS setting seems to be OK.

    What is the problem of my ISPConfig webpanel so that I cannot access it with domain URL? How to solve such a problem? Kind helps are much appreciated.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    When a domain or subdomain does not exist in DNS, then you can't use it. So there is no problem with your ISPConfig panel or access to it, you have a problem with your DNS record and this causes the domain to not function and this causes that you can't access ISPConfig by that domain. So to solve your problem, you must fix the root cause, which is the missing or non-working dns record.

    Please post the real domain name as we can't lookup the dns without it to help you with our dns issue.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

  4. kettgun

    kettgun New Member

    Dear Till, thanks for the guideline, and sorry for late response as I tried to solve the dns issue by trial and error based on your clue. Now my website can be accessed through domain but intodns.com consistently reported one Fail, two Errors (see attachment). So, I try to fix as follows:
    Prior to that, I would like to inform that in my Domain Provider (DP) website I put ns1.mydomain, ns2.mydomain, ns3mydomain, ns4mydomain (I just replaced 4 default ns given by DP with my domain). Actually, I have only one vps server. Then, If I fill DNS record in ISPConfig with such four ns , and in who.is only 2 ns do appear with strange name/double domain (ns1.mydomain.mydomain and ns2.mydomain.mydomain) . To remove one mydomain in such double domain, I tried to fill NS with only ns1-ns4.without domain), and the results in who.is and intodns.com are ns1, ns2, ns3,ns4(without domain). This seems to affect the next effort to change the setting. Now, If I fill only two ns (ns1.mydomain and ns2.mydomain), in who.is they become ns1 and ns2 (without domain). If I fill four ns (ns1.mydomain, ns2.mydomain etc), the results are only two ns with strange name/double domain (ns1.mydomain.mydomain and ns2.mydomain.mydomain).

    My questions are: 1) Because the message in the error mentions 4 ns, should I fill 4 NS in ISPConfig? Is it okay if I fill DNS records with only one or two ns? How to fix the above problems? Do you think that such problems cause the roundcube webmail cannot send and receive email? Thank you.
     

    Attached Files:

  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Are you using ISPConfig to host your name service? If yes, have you read the Tutorial @till mentioned and followed it?
    Two nameservers is enough.
    Yes.
    If name service is not set up properly for the e-mail server, sending and receiving e-mails does not work. Whether from Roundcube or somewhere else.
    There is Tutorial for setting up e-mail server with ISPConfig: https://www.howtoforge.com/how-to-install-an-email-server-with-ispconfig-on-debian-10/
     
  6. nhybgtvfr

    nhybgtvfr Active Member

    what you have visible in attachment 3 looks ok. now you need to create new A records for ns1 and ns2 as well.
    also, if you haven't already, in your domain providers control panel, you also need to provide glue records, basically, the ip addresses for your two nameserver entries. this is because you are using nameservers for the same dns zone they are members of.

    for the PTR record in attachment 4, as it says, you will have to ask whoever is responsible for the ip range your public ip's are in to configure that record for you.
     
  7. kettgun

    kettgun New Member

    Yes, I use ISPC to host my nameservice. I already read it, but can't manage it :) Not sure, which dns record I miss it.
    OK. It seems more simple managing two ns.

    Thanks for the information, so I have to resolve the name service first in ISPC. Previously,I have tried using "V"CP; it works perfectly both the nameservice and email (I can send and receive email).
     
  8. kettgun

    kettgun New Member

    OK. I will try it.
    I have only access to propose ns1-ns4, and the domain provider even didn't ask me the IP number. In case I can't manage name service in my ISPC, is it possible I change it to the default ns1-ns4 of the domain provider? Should I inform the IP of my server to the provider? Could you explain a bit more for this?

    I will strive to use my ISPC for nameservice first, and for resolving the error I should ask the domain provider about the PTR. Thank you.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Post a screenshot of the records tab of the zone as you have it now.

    If you have just a single server, then it makes not much sense to set 4 name servers at your domain provider. It should be enough to set 2 name servers. When you e.g. set ns1.yourdomain.tld and ns2.yourdomain.tld as name server, then ns1 and ns2 must exist as NS records in the zone that you create in ISPConfig but they also must exist as A-Records. If the A-records are missing, then BIND will reject to load the DNS zone.

    That the provider does not ask for an IP address is a bit strange as this would mean that you can't set glue records and without glue records, you can't use subdomains of the same domain name as NS records. Btw. That's all not ISPConfig specific, that's the way DNS in the internet works, so it applies to any control panel you use.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    But in general, hosting your own DNS makes only sense when you have a larger number of domains and you run several servers. If you have just a few domains or run just a single server, then it's often better to use the free DNS service which is offered by most domain registrars.
     
  11. kettgun

    kettgun New Member

    In A record, IP address is required so in Name I fill with ns1.mydomain and ns2.mydomain, and in Data I fill with IP. The results are: in who.is ns becomes ns1.mydomain.mydomain, and in intodns.com it creates additional one error. The results are the same if in Name I only fill with ns1.(withoutdomain) and ns2.(withoutdomain) (see attachment)
     

    Attached Files:

  12. kettgun

    kettgun New Member

    .
    The records tab I have it now is as attached in attachment3, and DNS zone in the above attachment named dns. It's strange, although I have remove ns1 and ns2 in A record, the results in whois and intodns are the same (attachment new-whois and new-intodns). You can check it in whois and intodns if this is a cache issue.

    OK, I will contact the domain provider

    Can you give me an example of this?
     
  13. nhybgtvfr

    nhybgtvfr Active Member

    Use ns1 and ns2 or ns1.mydomain.tld. And ns2.mydomain.tld.

    Note the trailing . Its the end of the complete record, if you dont use the trailing . the domain name is automatically appended.
     
  14. kettgun

    kettgun New Member

    I just tried in Name column (DNS record) with ns1 and ns2 (without dot) as well as ns1.fisip-unmul.net. and ns2.fisip-unmul.net. (with dot). In Data column I fill it with IP number. The results are the same as previously mentioned in the attachment.
     
  15. kettgun

    kettgun New Member

    I just tried it by using ns1 and ns2 (without dot) as well as ns1.fisip-unmul.net. and ns2.fisip-unmul.net (with dot). The results in who.is and intodns are the same, as attached in my previous message.
     
  16. nhybgtvfr

    nhybgtvfr Active Member

    the whois information will not change. the nameserver entries there come from the domain registrar, not your dns.

    dns changes can take a while to propagate, they can easily take 48-72 hours for changes to update worldwide, although lower TTL's should speed that up. but even then, some dns servers appear to ignore the ttl's and update on their own schedule.

    try using nslookup,
    nslookup fisip-unmul.net
    nslookup ns1.fisip-unmul.net

    will return the A records from whatever nameserver your current pc is configured to query

    nslookup ns1.fisip-unmul.net 8.8.8.8
    nslookup ns1.fisip-unmul.net ns1.fisip-unmul.net

    will query the a record for your first nameserver from one of google's nameservers (1st line) or your own domains registered nameservers (2nd line)

    you can also specify which record you want to check.

    nslookup -q=ns fisip-unmul.net 8.8.8.8
    nslookup -q=ns fisip-unmul.net ns1.fisip-unmul.net

    will do the same as the previous lookups, but check the nameserver records instead of the A records.

    I've just checked your records, using nslookup, intodns and mxtoolbox, and they look to be set correctly right now.

    nslookup ns1.fisip-unmul.net ns1.fisip-unmul.net
    Server: ns1.fisip-unmul.net
    Address: 103.27.206.139#53
    Name: ns1.fisip-unmul.net
    Address: 103.27.206.139

    nslookup -q=ns fisip-unmul.net ns1.fisip-unmul.net
    Server: ns1.fisip-unmul.net
    Address: 103.27.206.139#53
    fisip-unmul.net nameserver = ns2.fisip-unmul.net.
    fisip-unmul.net nameserver = ns1.fisip-unmul.net.

    [​IMG] NS records from your nameservers NS records got from your nameservers listed at the parent NS are:
    ns2.fisip-unmul.net ['103.27.206.139'] [TTL=3600]
    ns1.fisip-unmul.net ['103.27.206.139'] [TTL=3600]

    NS ns1.fisip-unmul.net 103.27.206.139 BEON-AS-ID (AS55688) 60 min [​IMG] 265 [​IMG] [​IMG] [​IMG]
    NS ns2.fisip-unmul.net 103.27.206.139 BEON-AS-ID (AS55688) 60 min [​IMG] 265 [​IMG] [​IMG] [​IMG]
     
  17. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  18. kettgun

    kettgun New Member

    This is my steps in solving the problem. First, following Till’s suggestion, in domain provider company, I have changed the number of ns into two: ns1.fisip-unmul.net and ns2.fisip-unmul.net. I have also requested to create a glue record by giving my IP number. To the VPS hosting company, I requested to fix PTR record. Few hours later, the companies (domain provider & VPS provider) informed me it has been changed following my request.

    Second, I reinstalled ubuntu by using vps rebuild and ISPconfig by using automated installation (because of my dependencies problem). So the current installation is a fresh OS and ISPC. What mentioned by nhybgtvfr regarding nslookup seems to be the previous installation as a results of many trials and errors and I do not know what is actually the problem. As I want to know the root cause, I reinstall it.

    Third, I have configured DNS Zone and DNS records in ISPC by following the guideline as mentioned in the thread. I even fill A record with ns1.fisip-unmul.net and ns2.fisip-unmul.net with IP 103.27.206.139 mentioned by nhybgtvfr and also found in the tutorial mention by Taleman. The results are the same.
    - In who.is DNS record says “No DNS Records found”.
    - In intodns, we have 7 errors/red background (see attachment).
    - In nslookup of MXToolbox, it says : “DNS No Valid NameServers Responded: Not able to get a response from name servers within timeframe”
    - I still cannot access ISPC domain URL http://fisip-unmul.net:8080 (I can only access it from http://103.27.206.139:8080)

    I think the problem is in ISPC installation related to automated installation, so I follow the Testing tutorial mentioned by Taleman.

    [email protected]:~# host fisip-unmul.net 103.27.206.139
    ;; connection timed out; no servers could be reached
    [email protected]:~# host srv.fisip-unmul.net 103.27.206.139
    ;; connection timed out; no servers could be reached

    [email protected]:~# systemctl status bind9.service
    ● bind9.service - BIND Domain Name Server
    Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: enabled)
    Active: inactive (dead)
    Docs: man:named(8)
    May 02 14:59:17 srv.fisip-unmul.net named[9101]: no longer listening on 10.10.128.86#53
    May 02 14:59:17 srv.fisip-unmul.net named[9101]: exiting
    May 02 14:59:17 srv.fisip-unmul.net systemd[1]: Stopped BIND Domain Name Server.
    May 02 15:41:01 srv.fisip-unmul.net systemd[1]: bind9.service: Unit cannot be reloaded because it is inactive.
    May 02 16:15:04 srv.fisip-unmul.net systemd[1]: bind9.service: Unit cannot be reloaded because it is inactive.
    May 02 16:17:03 srv.fisip-unmul.net systemd[1]: bind9.service: Unit cannot be reloaded because it is inactive.
    May 02 16:18:01 srv.fisip-unmul.net systemd[1]: bind9.service: Unit cannot be reloaded because it is inactive.
    May 02 16:43:02 srv.fisip-unmul.net systemd[1]: bind9.service: Unit cannot be reloaded because it is inactive.
    May 02 21:33:03 srv.fisip-unmul.net systemd[1]: bind9.service: Unit cannot be reloaded because it is inactive.
    May 02 21:35:03 srv.fisip-unmul.net systemd[1]: bind9.service: Unit cannot be reloaded because it is inactive.

    [email protected]:~# named-checkzone 250.168.192.in-addr.arpa /etc/bind/pri.250.168.192.in-addr.arpa.err
    zone 250.168.192.in-addr.arpa/IN: loading from master file /etc/bind/pri.250.168.192.in-addr.arpa.err failed: file not found
    zone 250.168.192.in-addr.arpa/IN: not loaded due to errors.

    I think the problem is Bind9, and then…
    [email protected]:~# service bind9 start
    Domain URL is now running well. For roundcube that still cannot send and receive email, I will try searching the solution in this forum.

    Thank you Till, nhybgtvfr, and Taleman.
     
  19. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  20. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You were supposed to check what *.err files there are in that directory, and use those as arguments for named-checkzone. You do not use 250.168.192.in-addr.arpa zone so you do not have that file. Also reading man named-checkzone is helpful.
     

Share This Page