[SOLVED] Can't send email from my server

Discussion in 'Installation/Configuration' started by AxelssonDesign, Dec 17, 2019.

  1. I can't send email from my SMTP server. I can send mail to other domains hosted on same server but can't send to other outside my domain.

    How to fix ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look into the mail.log of the server.
  3. Here is the message that will not go through.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That's a received message which has been received successfully.
  6. Steini86

    Steini86 Active Member

    That are only people trying to connect to your server. Nothing to worry about. If your mail is in the queue (see with "mailq" command), then use "postfix -f && tail -f /var/log/mail.log" to start sending and see the error message
  7. #mailq
    Mail queue is empty

    # postfix -f && tail -f /var/log/mail.log
    postfix: invalid option -- 'f'
    postfix: fatal: usage: postfix [-c config_dir] [-Dv] command

    Where can I find the log for problem in sending email ?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. This is the file I'm reading but I can´t find more relevant errors.

    Here is my main.cf:

  10. Steini86

    Steini86 Active Member

    Then, what 'exactly' is not working? Everything you have shown so far works?
    Use "tail -f /var/log/mail.log" to observe your logfile. Then sent an email via SMTP to a local domain and an outside domain. Post the logs here.
  11. zix.is same domain - zenfors.se hosted on g-suite

    PS. Got red on thise line in master.cf
    -o milter_macro_daemon_name=ORIGINATING
  12. Steini86

    Steini86 Active Member

    Your server thinks that zenfors.se is a local domain and stores the mail into a local mailbox. From here it looks like it is working as you configured it ;-)

    Have you changed something in /etc/postfix/mysql-virtual_client.cf ?
    When you change something in /etc/postfix/sasl_passwd you should do a "postmap /etc/postfix/sasl_passwd" and restart postfi afterwards
  13. works now :) problem was I did't delete mail-domain/box after moving mail to g-suite.

    ps. ertu íslenskur steini86 ?
    Steini86 likes this.
  14. Steini86

    Steini86 Active Member

    Glad you could solve it!
    No, sry. I'm a German, currently in the US
    AxelssonDesign likes this.

Share This Page