[Solved]Cannot Send/Receive email - ISPConfig3.1 - Port 25 Blocked by ISP

Discussion in 'Installation/Configuration' started by George321, Jan 12, 2017.

  1. George321

    George321 New Member

    Hello,
    My problem is that i cannot receive or send emails.
    My server isn't blacklisted, i checked it here: mxtoolbox. com/blacklists.aspx
    I have spoken with the provider and he blocks the port 25.
    i have also tried this: telnet smtp.gmail.com 587 and it connects so i can use the port 587.
    But i want your help configuring my system.
    I use horde but i havent any problem using the default SquirrelMail app.
    Extra info:
    Mail - Log > pastebin{.}com/SFwsv0Wn

    Thanks a lot
     
    Last edited: Jan 12, 2017
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Email is sent and received between servers on port 25, so you wouldn't be able to send or receive even if you weren't blacklisted.
     
    George321 likes this.
  3. George321

    George321 New Member

    How to change port from 25 to 587?
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    You can send mail through an external server/service on port 587, but you cannot receive mail there, all external servers will use port 25. You simply cannot run an smtp server without port 25 open. You could put up a secondary server somewhere else that does allow port 25 the accept mail and forward to you on 587; or you could buy a service from somewhere which does a similar thing. Or either convince your provider to open port 25, or move your server to another network segment (colocated or vps or something) where it isn't blocked.
     
  5. George321

    George321 New Member

    Today i talked with my provider and he said that.
    I can receive emails from port 25 but i cant send.
    For sendind emails i must use the 587/submission port.

    So what i have to do now? Thanks
     
  6. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    If you can not send mails over port 25, you must use an external server that accepts your mails on port 587.
     
  7. George321

    George321 New Member

    i reinstalled ISPConfig in a fresh debian system. And configured it carefully.
    Now i can receive emails.

    But i dont know how to configure my server to use external server to send emails
    EDIT:
    I used these 2 tutorials and now i can send also emails via port 587
    -https://www.linode.com/docs/email/postfix/configure-postfix-to-send-mail-using-gmail-and-google-apps-on-debian-or-ubuntu

    -https://easyengine.io/tutorials/linux/ubuntu-postfix-gmail-smtp/
     
    Last edited: Jan 14, 2017
  8. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    The tutorials do not configure your server to send mails using port 587. You just send your mails using your gmail-account. That's what i wrote in #6.
     
  9. George321

    George321 New Member

    yeah but that is all i can do with port 25 blocked for outgoing. right? Thanks
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    You can only send trough a relay server when port 25 is blocked, there are no other options then relaying trough another server or getting a real server in a datacenter where port 25 is not blocked.
     
  11. George321

    George321 New Member

    Thank you very much i didn't know that.
     

Share This Page