[solved][access denied] connect ns2 while install.php to master

Discussion in 'ISPConfig 3 Priority Support' started by Frankenstein, Sep 26, 2018.

  1. Frankenstein

    Frankenstein Member

    Heyho - it's Frankenstein again!

    While my 7 server multi setup (control, web, db, mail, ns1, ns2, ns3) i have some troubles while connecting to the mysql master server from my ns2 setup (install.php).

    sys info:
    debian 9.5

    mysql users created on master with following commands:
    CREATE USER 'root'@'ip.of.ns2.server' IDENTIFIED BY 'my-pass';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'ip.of.ns2.server' IDENTIFIED BY 'my-pass' WITH
    GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0
    MAX_USER_CONNECTIONS 0 ;
    CREATE USER 'root'@'ns2.domain.tld' IDENTIFIED BY 'my-pass';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'ns2.domain.tld' IDENTIFIED BY 'my-pass' WITH
    GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0
    MAX_USER_CONNECTIONS 0 ;
    FLUSH PRIVILEGES;

    The ns1, db and mail had no problems while connecting. The code for the other ones is configured copy&paste from the one above. The root-password in my commands are the same from the respective ones [email protected]
    checked #bind-adress 127.0.0.1 on 50-server.cf
    server is running good with no errors in mysql error log, syslog, auth log
    checked /etc/hosts
    checked /etc/hostname > ns2.domain.tld


    Struggle - any idea?

    Best regards
    Frankenstein


    //edit

    I've done a server rebuild and built it up the same time and way the ns3 - each step. ns3 had no problems while install.php - ns2 the same issue.

    //edit2
    in my password was a \e what corrupts the password entry......solved
     
    Last edited: Sep 27, 2018

Share This Page