software raid1 on running system incl grub2 ubuntu 10.04

Discussion in 'HOWTO-Related Questions' started by Hajo.Locker, Oct 14, 2011.

  1. Hajo.Locker

    Hajo.Locker New Member

    Hello,

    i tried this howto.

    http://www.howtoforge.com/how-to-se...-system-incl-grub2-configuration-ubuntu-10.04

    I also use Ubuntu 10.04(32). The difference ist that iam not having special /boot partition. /boot is located on / (/ is sda3, sda2 is /tmp and sda1 is swap)

    i processed this howto and every time where sdb1/md0 was used i replaced with sdb3/md2
    Problem is rebooting, df -h (start of page3) dont shows md2 for /, it is still sda3

    dont really find my mistake, fstab and mtab are edited as well.
    this is my /etc/grub.d/09_swraid1_setup
    root should be md2 in my case.


    #!/bin/sh
    exec tail -n +3 $0
    # This file provides an easy way to add custom menu entries. Simply type the
    # menu entries you want to add after this comment. Be careful not to change
    # the 'exec tail' line above.
    menuentry 'raid1 test 2.6.32-34-generic-pae ' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod raid
    insmod mdraid
    insmod ext2
    set root='(md2)'
    linux /boot/vmlinuz-2.6.32-34-generic-pae root=/dev/md2 ro quiet
    initrd /boot/initrd.img-2.6.32-34-generic-pae
    }


    sda3 still on / blocks adding sda3 to my array md2. md0 and md1 works as expected.
    What could be my mistake? additional confs needed?


    Thanks for help,
    Hajo
     
    Last edited: Oct 14, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/fstab and /etc/mdadm/mdadm.conf? What are the outputs of
    Code:
    cat /proc/mdstat
    and
    Code:
    fdisk -l
    ?
     
  3. Hajo.Locker

    Hajo.Locker New Member

    Hello,

    thanks for your help.

    I did it again and this time it was successful. May be a small mistake at the first attempts.

    Thanks for the great Howto.

    Thanks,
    Hajo
     
  4. Hajo.Locker

    Hajo.Locker New Member

    Hello,

    just 1 short question.
    I changed partition type of my /tmp also to fd - Linux raid autodetect. Ist this needed or should better stay at 82 - Linux Swap / Solaris? Seems to work in both cases.

    Thanks,
    Hajo
     
  5. falko

    falko Super Moderator ISPConfig Developer

    That's up to you as /tmp should contain only temporary data.
     
  6. Hajo.Locker

    Hajo.Locker New Member

    thanks, i retained now as 82 - Linux Swap.

    At another test making a raid1 i had again my initial problem. System was not booting from md2, it still uses sda3 for startup.

    Again i did not find any problem in my files.
    Now i changed:
    update-initramfs -u
    to:
    update-initramfs -u -k all
    as mentioned in other readmes and it worked.

    This could be the mistake? I dont really know...

    Hajo
     

Share This Page