Soft limit and Hard limit

Discussion in 'ISPConfig 3 Priority Support' started by Marcio Urakawa, Jun 10, 2020.

  1. I would like to know how can I configure these values that appear as unlimited?
    In item 4.6.6.3 of the manual it says to enable the "Grace Period" but I haven't found where.
    [​IMG]

    I wanted to configure it so that when it reached that soft limit value, it would send a notification to the user.
     
  2. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    You can set the limits for the website under Sites -> domain -> Harddisk quota
     
  3. I did it, set it to 400MB but on the home screen it appears as unlimited.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It may take some time until it gets updated, this is not realtime.
     
    Marcio Urakawa likes this.
  5. I sent some files with an average of 100mb but still the screen does not change. It keeps appearing unlimited
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe your hard disk is not configured for Linux quota. Post the result of:

    repquota -avu
     
    Marcio Urakawa likes this.
  7. [​IMG]

    Code:
    du -sh /var/www/clients/client5/web23
    67M     /var/www/clients/client5/web23
     
    Last edited: Jun 11, 2020
  8. Is there anything that can be done?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that you really enabled quota on the harddisk partition that contains the websites. maybe you have a separate partition for /var or /var/www but quota is enabled only for another partition.
     
  10. My /etc/fstab

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    devpts          /dev/pts        devpts  rw,noexec,nosuid,gid=5,mode=620 0  0
    /dev/xvda1 none swap sw 0 0
    /dev/xvda2 / ext4 errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 1
    /dev/xvda3 /var ext4 defaults 0 1
    /dev/xvda4 /home ext4 defaults 0 1
    /dev/xvda5 /var/log ext4 defaults 0 1
    /var/log/ispconfig/httpd/howtoforge2.com /var/www/clients/client5/web20/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/mydomain.com /var/www/clients/client14/web30/log    none    bind,nobootwait    0 0
    
     
  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    So, have you
    Which partition is it that contains the websites?
    If it is /var like usual, that does not have quota.
     
  12. Yes, it's on / var / www

    Do you have any manuals for me to fix? Or would you have to reinstall?
     
  13. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Enable quota on /var, the same way it is done for /.
     
    Marcio Urakawa likes this.
  14. Sorry for the doubts, I performed the procedure as you told me and now the quota is showing in Ispconfig.
    One last question related to this, this soft alert set up where?
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not use that.
     
    Marcio Urakawa likes this.
  16. After reading about the quota system, and configuring / etc / fstab that way, it worked:
    Code:
    /dev/xvda3 /var ext4 relatime,errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 1
    One more question: I realized that the space used is not updated in real time, can I configure it for a shorter time?
    I click on resync to view the change.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    No, or not at least not without changing the code. And that's the statistics view only, the Linux filesystem calculates it in real time, so you can't upload more files than what your quota allows.
     

Share This Page