SOAP Error: looks like we got no XML document

Discussion in 'General' started by nokia80, Nov 6, 2013.

  1. nokia80

    nokia80 Member HowtoForge Supporter

    hi
    since yesterday does not work the cron job no matter what script I use which website the problem remains the same.

    SOAP Error: looks like we got no XML document


    I like to hear from someone
     
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    What cron job do you mean? Please provide some more details.
     
  3. nokia80

    nokia80 Member HowtoForge Supporter

    hi,

    thanks fore repley its the cron from whmcs that runs every night.

    when i do it manual xxxx.xx/admin/cron.php i get the error it works always now i have this error.

    i hope you know more.

    thanks
     
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Have you made any updates, recently?
    There are some soap problems due to changes in the supported protocols e. g. debian uses to connect via ssl.
     
  5. nokia80

    nokia80 Member HowtoForge Supporter

    hi,

    yes i run debian

    and now that you mention it I do have the system updated apt-get update and apt-get upgrade.
     
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Have a look inside the cron script that does produce this error.
    It would be nice to know, what is done inside. Without code it is hard to guess what is going wrong.

    If you have lines like this in it
    PHP:
     $fp fsockopen("ssl://myserver.com"$port$errno$errstr30);  
    try changing them to
    PHP:
     $fp fsockopen("sslv3://myserver.com"$port$errno$errstr30);  
    ssl -> sslv3
     
  7. nokia80

    nokia80 Member HowtoForge Supporter

    pfff oke


    than i have a problem cron.php in whmcs is all ioncube_loader.

    i use ioncube_loader_lin_5.4.so
     
  8. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Hm, I think you will have to contact support of the plugin then, sorry.
     

Share This Page