Soap Error: login_error_regex

Discussion in 'Developers' Forum' started by Claudio.Bartolini, Nov 24, 2011.

  1. Claudio.Bartolini

    Claudio.Bartolini New Member

    Hello everybody,

    I'm trying to use "mail_user_add.php" function, but the result is...

    Logged successfull. Session ID:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    data_processing_errorlogin_error_regex<br> SOAP Error: login_error_regex

    Remote user has been created successfully into ISPConfig Version 3.0.4.

    The content of my "soap_config.php" file:
    $username = 'MYUSERNAME';
    $password = 'MYPASSWORD';
    $soap_location = 'http://MYIPADDRESS/ispconfig/remote/index.php';
    $soap_uri = 'http://MYIPADDRESS/ispconfig/remote/';

    Any idea to solve this problem??? Thanks in advance.

    Claudio
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Most likely your username contains chars that are not allowed for remote usernames. Please chnage the username so that it contains only the chars a-z and numbers 0-9
     
  3. Claudio.Bartolini

    Claudio.Bartolini New Member

    Uhm.... username and password contains only allowed chars...
    Username "claudio" and password "claudio", got the same error... :(
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, I misinterpreted the error message. The error message is most likely related to the login field of the mail_suer_add function.

    Ensure that you have set the field 'login' in the $params array. The content of this fieldis normally the email address.
     
  5. Claudio.Bartolini

    Claudio.Bartolini New Member

    Uhm... maybe it's me... I didn't understand how it works...
    I'm just calling the mail_user_add.php example page to see if it works...

    But... where is the login field?
    $params = array(
    'server_id' => 1,
    'email' => 'hmmnoe@test.int',
    'password' => 'howtoforge',
    'name' => 'hmmnoe',
    'uid' => 5000,
    'gid' => 5000,
    'maildir' => '',
    'quota' => 10000000000,
    'cc' => '',
    'homedir' => '',
    'autoresponder' => 'n',
    'autoresponder_start_date' => '',
    'autoresponder_end_date' => '',
    'autoresponder_text' => 'hallo',
    'move_junk' => 'n',
    'custom_mailfilter' => 'spam',
    'postfix' => 'n',
    'access' => 'n',
    'disableimap' => 'n',
    'disablepop3' => 'n',
    'disabledeliver' => 'n',
    'disablesmtp' => 'n'
    );

     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    It is missing in the code that you posted:

    'login' => 'hmmnoe@test.int',

    The new parameter is required starting from ISPConfig 3.0.4. I've fixed that in the api example too.
     
  7. Claudio.Bartolini

    Claudio.Bartolini New Member

    Great, it works!

    Very happy to have found a "bug" :)

    Thank you very much!
     
  8. maumar

    maumar New Member HowtoForge Supporter

    roundcube plugin ispconfgi3 is not compliant, too
    with 3.0.4.x ispconfig
    i added login line:
    Code:
          'email' => $this->rcmail_inst->user->data['username'],
          'login' => $this->rcmail_inst->user->data['username'],
    
    after email and now I am able to change password
     
  9. maumar

    maumar New Member HowtoForge Supporter

    this is the exact diff:
    Code:
    --- /root/roundcubemail/plugins/ispconfig3_pass/ispconfig3_pass.php     2011-10-10 06:48:08.000000000 -0400
    +++ /var/www/roundcubemail/plugins/ispconfig3_pass/ispconfig3_pass.php  2011-12-15 07:26:19.000000000 -0500
    @@ -70,6 +70,7 @@
     
                                            $params = array('server_id' => $mail_user[0]['server_id'],
                                                                            'email' => $this->rcmail_inst->user->data['username'],
    +                                                                       'login' => $this->rcmail_inst->user->data['username'],
                                                                            'password' => $newpwd,
                                                                            'name' => $mail_user[0]['name'],
                                                                            'uid' => $mail_user[0]['uid'],
    
    
     
  10. beliashou

    beliashou New Member

    The same error message in forward feature. Add the same line in ispconfig3_forward.php. Works good!
     
  11. Horfic

    Horfic Member

    its fixed since svn version 116, 116 got also a lot of bugfixes
     
  12. maumar

    maumar New Member HowtoForge Supporter

    Last edited: Jan 11, 2012
  13. maumar

    maumar New Member HowtoForge Supporter

  14. maumar

    maumar New Member HowtoForge Supporter

    rev. 119 with ispconfig 3.0.4.2 and rc 0.7

    account page seems to have a very larg left frameset, llike in screenshot attached
     

    Attached Files:

  15. Horfic

    Horfic Member

    See Troubleshooting: http://bugs.web-wack.at/documents/3

    Q: The plugins are looking weird (left side huge, right side small).
    A: You forgot to activate the jqueryui plugin, it hast to be before the ispconfig3 plugins in the plugin list.

    The jqueryui plugin is a new dependency for the autoreply plugin.
     
  16. maumar

    maumar New Member HowtoForge Supporter

    for dummies people like me...
    something like this:

    Code:
    
    $rcmail_config['plugins'] = array('jqueryui',
                                        'ispconfig3_account', 'ispconfig3_autoselect', 'ispconfig3_pass', 'ispconfig3_autoreply', 'ispconfig3_forward');
    
    
    'jqueryui' is the first one :)
     

Share This Page