Soap Error: Could not connect to host - roundcube

Discussion in 'Plugins/Modules/Addons' started by Stelios, Sep 19, 2020.

  1. Stelios

    Stelios Member

    Hi all,

    I've installed Roundcube as per docs & online git instructions on a multi-server setup.
    I've double-checked that Roundcube username+password when I create the user via the ISPconfig menu is correct and that all plugins/settings are in place but still getting the "Soap Error: Could not connect to host"

    My soap related config.inc.php:
    PHP:
    <?php
    $config
    ['identity_limit'] = false;
    $config['remote_soap_user'] = 'roundcube';
    $config['remote_soap_pass'] = 'mypass';
    $config['soap_url'] = 'https://myip:8080/remote/';
    $config['soap_validate_cert'] = true;
    I tried with false too on the cert (but I got a letsenctypt in place) but the same problem.

    Any help is very much appreciated.

    Thanks
     
    Last edited: Sep 19, 2020
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Do you have a valid SSL sert for your IP (as it seems you are connecting to the IP address directly)?
     
  3. Stelios

    Stelios Member

    Hi Thom,
    I've got a Letsencrypt in place so when I access for example the https://mycontropanel.com:8080 there is no error.
    I tried however with IP, with hostname and with and without the SSL true/false in the config and in all cases same error.
    The rouncube is installed on my mail server which holds just the controlpanel & roundcube/phpmyadmin.
     
  4. Stelios

    Stelios Member

    Thom, you were correct. I had a typo with hostname, when I switched from IP to hostname it worked.
    Many thanks for your help.
     
    Th0m likes this.

Share This Page