So, my Debian Lenny root server doesn't boot any more

Discussion in 'Installation/Configuration' started by thec, Oct 13, 2010.

  1. thec

    thec New Member

    I have an EQ 4 root server at hetzner.de running Debian Lenny. They moved my server yesterday from one data center to another and I had to shut it down.
    I set up the server with Xen and two guest machines a year ago without much trouble by reading the tutorials here. I know a bit about Linux, but I'm not a pro and thus I need help (I'm pretty desperate right now, because the server hosts a website for a couple thousand people).

    I did the following:
    - I tried to suspend the DomU's, but it didn't work (weird error message about Xen lifecycle).
    - I 'saved' DomU B (the unimportant one), which worked well.
    - I tried to 'save' DomU A (the important one), which didn't work too well. It seemed that I lost my SSH connection. I started to ping the server and got an ICMP echo reply once in 20 packets or so. After a minute or two, the "xm save" command seemed to be complete (don't know how, but a few packets came though). Then I lost my SSH connection. I thought that Hetzner started earlier with their move or something like that.
    - In the morning, I tried to login with SSH. Didn't work. Ping resulted in a reply once in every 20 packets or so again
    - I started the rescue console (a minimal Linux system gets loaded into memory and the server restarts). That worked quite fine, so I suspect that no hardware errors occured with the move. ping was stable in rescue mode.
    - I restarted once more into my old system. ping was unstable again
    - I restarted back into rescue system, trying to mount the old file systems and remove Xen from init.d, because I suspected it to cause troubles on startup (corrupt saving state maybe)
    - I restarted back into my old system, but somehow ping wouldn't return any results any more.
    - I went back and forth a couple of times without changing too much and noticed that the last logfiles (syslog) were from the morning.

    And that's the current state. In rescue system, everything works fine. My old system doesn't even produce any log messages in syslog or boot.

    I'm pretty desperate and I have entirely no clue what I could do. Any suggestions?

    Edit:
    I have a RAID 1 with 2 750GB HDDs and the Xen DomUs run on LVM, not image-based.
    "fsck" didn't return any errors.
     
  2. falko

    falko Super Moderator ISPConfig Developer

Share This Page