So close to getting 3D on my ATI graphics card, please help me finish

Discussion in 'HOWTO-Related Questions' started by thirtythree, Sep 23, 2007.

  1. thirtythree

    thirtythree New Member

    Alright, here goes nothing... I have been working on a solution to this problem for about a week now, and I have made a ton of progress and learned a lot. But I still have not solved the problem, and I need some help to figure out where to go next.

    Let me preface this with saything that I am a soldier who is currently in Iraq, and who has an extreemly slow internet connection at the moment. It is difficult for me to get online, so I am going to post this message in a few different forums. Please don't get upset if you see it elsewhere. I will post my solution to all forums as soon as I get one (to help others out).

    Here is the deal. I am running open SuSE 10.2 with kernel Linux i686 on my core duo laptop. I have an ATI Mobility x1300 graphics card (wish I had an nVidia, this problem would go away). I have been trying to enable the card's 3D capabilities in every ounce of my spare time for the last week.

    I have been using the ATI HowTo from, it has been very helpful. I have also been using the latest ATI driver from the ATI website. The current driver I have been using is . It didn't used to install smoothly when I used the 2.6.18 kernel that openSuSE 10.2 came with. So I learned how to compile and install a new kernel ( Holy cow, that was a learning experience, but it went well.

    The driver installs fine. But like so many other across these forums, I don't have the card's 3D capabilities. Running glxinfo is supposed to give something like this...
    But instead it give this...
    With this at the beginning...
    I have tried so many different "solutions" found in the ATI HowTo, and in these forums. I have tried turning off compositing, AIGLX, and changed a slew of the options under devices to the various suggestions I have found in other forums. Nothing works. The one possibility is that my XFree86 version is too new? I can't figure out if this is right, or how to fix it (I don't even know how to figure out what version I have).

    I have worked on this problem for too long to give up now. I can tell I am close. So close. Any help would surely make my day so much nicer (and allow me a nights sleep). What follows is some more relevant information.

    The full output of glxinfo...
    The full output of fglrxinfo...
    I will reply with my xorg.conf file in a moment...

    Thank you again for any help. Ask anything you need and I will try to respond promptly if possible. Thank you.

  2. thirtythree

    thirtythree New Member

    Here is my xorg.conf

    My current xorg.conf file (there have been many other versions in my attempts, this is pretty much just what Sax2 spit out)...
  3. falko

    falko Super Moderator ISPConfig Developer

  4. thirtythree

    thirtythree New Member

    Hey Falko, I appreciate it, but I'm not trying to get Beryl to run. Just my card's capabilities. I have narrowed the problem down to the following...
  5. tmick

    tmick New Member

  6. thirtythree

    thirtythree New Member

    ATI Radeon Mobility x1300 is now running 3D with the fglrx driver. This is how I did it:

    I want to preface this with the following: I am fairly new to linux, and have spent the last week or so trying desperately to get this up and running. I searched all over the internet and found a million threads like this one. I tried everything I could find, nothing worked. In the end, what worked was to read every ounce of documentation provided with the driver, my video card, and my operating system, including the error logs. Half the time, I didn't know what I was reading. So I took notes, documented my progress, deduced the best possible course of action.

    On the night that I got this working, I started fresh. Spent 6 hours reading everything from the beginning, and kept a log. At the end of the 6 hours, I enacted a game plan that I had just came up with. I got my card working ON THE FIRST TRY. So the lesson is, understand what you are doing, and read till your eyes bleed. Nothing is easy if you look for an easy fix. Best to hack at it and understand why things are how they are. Without further ado...

    My setup:
    open SuSE linux 10.2
    KDE 3.5.5
    ATI Radeon Mobility x1300
    32 bit
    Dell Inspiron E1505 laptop, Intel Core Duo

    I don't know enough about linux to know if the following steps will work on anybody elses card or kernel. Like I said above, use your reading skills to read the documentation. It should tell you exactly what you need to know.

    Note: You must be using kernel 2.4 or higher

    Step 1. Download the driver from the ATI site. I downloaded, this was the most current driver as of this week.

    Step 2. While at the ATI website, grab the provided documentation for your driver. You will need this for further steps.

    Step 3. You must have shared memory enabled to use the 3D features of this driver. To do this, go add this line to your /etc/fstab :
    tmpfs /dev/shm tmpfs defaults 0 0
    (note - unless you reboot, you will need to mount this, use mount /dev/shm)

    Step 4. Use your respective software installation tool (Yast) to ensure you have all the proper dependencies for the driver. These include the following:

    # glibc version 2.2 or 2.3
    # XOrg 6.7, 6.8, 6.9, 7.0, 7.1, or 7.2; XFree86 version 4.3
    # XFree86-Mesa-libGL
    # libstdc++
    # libgcc
    # XFree86-libs
    # fontconfig
    # freetype
    # zlib
    # gcc
    # kernel-source (this must match your kernel-default version)
    # qt3
    # compat
    # compat-libstdc++
    # libstdc++-devel
    # xorg-x11-libs
    # xorg-x11-devel
    # Mesa
    # Mesa-devel
    # fontconfig-devel
    # expat
    # freetype2
    # freetype2-devel
    # zlib
    # zlib-devel
    # libdrm VERSION 2.3

    Step 5. As per the ATI documentation...
    So do an lsmod | grep agpgart and make sure it is in there.
    If you have been trying to install without this, you will know if from a bunch of errors about a kernel issue leading to a fail to install message.

    Step 6. If you have been trying to get this to work before, and have "installed" the driver before, you must clear your machine of all previous versions of the driver before you proceede.

    Go to runlevel 3 ->
    # su
    # init 3
    Then remove the previous driver
    # cd /usr/src/linux
    # make mrproper
    # make cloneconfig
    # make modules_prepare
    # make clean
    # rpm -e $(rpm -qa | grep fglrx)

    Step 7. Generate the driver package. Navigate to where you downloaded the driver and do the following ->
    # sh --listpkg

    Step 8. You will get a list of distributions from which you can build the driver, which looks like this...

    Build the distribution of your choice
    # sh ati*.run --buildpkg SuSE/SUSE102-IA32

    Step 9. Now you have a driver in /usr/src/packages/RPMS/i386
    So go to that directory
    # cd /usr/src/packages/RPMS/i386
    # rpm -Uvh fgl*.rpm

    See next post for the rest...
  7. thirtythree

    thirtythree New Member

    ...continued from previous post

    Step 10. Hopefully everything has gone smoothly from here. If you get a kernel error that says installation failed, its probably because you do not have agpgart enabled in your kernel.
    If everything has gone well...
    # ldconfig
    # aticonfig --initial --input=/etc/X11/xorg.conf

    Withouth agpgart, you will get something like this:
    Step 11. Your driver is now installed. Launch sax2...
    # sax2 -r -m 0=fglrx
    and configure your screen. In the test, you should see 3D without a line going through it. If you have this, then you have been successful.

    Step 12. Here is my xorg.conf file after everything is said and done...

    Look in the Module section to find some of the additional settings that I have added after the installation. These have been found to be the best options. Please do not cut and paste my xorg.conf into yours, I cannot guarantee that it will work.

    Step 13. Reboot.

    Step 14. Check to see that all works well. Run
    # glxinfo
    and make sure the beginning looks like this...
    and in the OpenGL vendor, you get this...
    and not this...

    Some end notes:

    -If this didn't work, check your logs:
    var/log/Xorg.0.log (use cat /var/log/Xorg.0.log | grep "(EE)")
    and read through them, look for the problem.

    -After installation there will be documentation here:

    -I used this repository to get many packages for SuSE 10.2 files
    type: ftp
    directory: /pub/

    -Double check apgart and posix

    -Don't give up. I have seen so many posts were people said that the x1300 card was impossible. Ha! I have dolphins and whales swimming around a 3D cube behind this editor as I write this. I can try to help if you leave a post here.

    I am a golden god.

Share This Page